freePBX newbie: Need help

Hey out there.
Today I installed FreePBX Distro, and it went fine.
I can now login to the GUI, and its awesome.

BUT: I remember when we did this in school… We had to type in the extension number and mac adress for each phone on the server. It was something like ‘FreePBX_menu_cisco’ because it was Cisco phones.

I now have two LG-Nortel IP8830 phones, and I don’t know how to add them on the server?
I have found the mac-adresses on the phones.

Also: I want to use these two phones “offline” = with no internet connection. I think the server can work as DHCP right? So that I only need to plug it into a switch, and connect my two phone to that switch. Is the server already set up as DHCP, or if not - how do I do this?

Hope someone out there will try to help me :wink:

why not just used a fixed IP for the phones. That way it won’t matter if you’re connected to the Internet or not. And a router is usually used to assign DHCP addresses on the network anyway. I don’t recall but I think you’re right, the Distro can be used as a DHCP server. Be careful about having two DHCP devices trying to hand out IP addresses on the same network. Personally I’d suggest the router method so you have a firewall in place when connecting to the Internet.

If you aren’t using the endpoint manager you don’t need the mac address. Just put the registration in the phone and you’re ready to go.

I’m using Grandstream phones so I can’t speak directly to the Cisco / LG-Nortel question.

Okay. I have a lot of questions…
My server and phones are on a router now, with internet connection too…

How do i change the server to run with a static IP? Fx.
Guess I’ll have to do this directly on the server using CLI commands, because I cant find it in the GUI.

I guess I’ll have to create extensions at the very first, right? Fx.
John <1001>
Peter <1002>

Then what?

  • I found a ‘SIP Configuration’ menu on my phones, with some settings:
  • Call Server Adress = The IP-adress of the server (I would guess)
  • Proxy Port = Its value now is 5060. Do I need to do something here?
  • Display Name = I guess this is only the name on the display on the phone itself.
  • Name = I dont know?
  • Auth. Username = I would say this is the extension number, or what? Fx. 1005?
  • Auth. Password = The secret you choose when you create a extension, right?
  • Reg. Status: Undefined = No Idea of what this means?
  • Line Type = Guess this has to be ‘Private’ or maybe ‘Shared’?

What really bothers me is that I cant just type in the IP-adress of the phone in the GUI? Because I can choose to set a static og a DHCP adress on my phone. I have now choosen a static.

Another question: When creating a extension. Do I have to choose Nat=Yes/No/Never?

Okay, I got it working with softphones… And my phones LED flashes for “Line not registered w/server”. So guess I have to assign the phones with their mac-adresses on the server, or?

You can use your phone server as a DHCP server. I do it often.

You have to install the DHCP server

yum install dhcp

and then configure it by editing the following file


You don’t really need to tell FreePBX the MAC of the phones unless you are using the End Point Manager to manage the configs of the phones.

I’ll just use the DHCP server in my router.
But I would like to have a static IP on my server. How do I do this??
I need some kind of CLI command.

How come the phones will not register w/server?
I set up the ‘SIP Configuration’ in the phones settings.

  • Has it anything to do with nat-settings in the GUI and in my router?

We appreciate your enthusiasm, the running commentary is not needed.

I suggest you read one of the getting started guides in our wiki. Remember PBX in a Flash, uses FreePBX also so most of the documentation on the web is relevant.

Assuming you used our ISO, it’s CentOS based so google “centos static ip” and see the many options you have available.

You can also change the IP and other settings in our commercial module “sysadmin”. You can purchase it in the store.

Have fun with your new PBX.

Static IP to server

log in to root from cli
go to ethernet config select eth0
select static and give the ip address
dont forget to save and exit
#service network restart
#network service restart
ping and check your static ip

Make it yes if you have to make an outbound/incoming call outside your router
for local lan calling NAT Not required

SIP Registration ( extension tab )
Name 101
SIP ID 101

keep username pass and other settings blank to make it easy

in the ip phone give name , sip id and sip server ip address port 5060


configure your router as DHCP server