FreePBX New Install on raspberry pi - filling SD card

Greetings I am a newbie to this forum, FreePBX and linux. Sorry if I am in the wrong forum. I just installed FreePBX on a rpi and am having a problem. I’ve loaded onto an 8Gb SD card
report says kernel 3.6.11
I am not over-clocking
I have run raspi-config and rebooted 3 times now
df -h returns

Filesystem Size Used Avail Use% Mounted on
rootfs 3.6G 3.0G 461M 87% /
/dev/root 3.6G 3.0G 461M 87% /
devtmpfs 212M 0 212M 0% /dev
tmpfs 44M 220K 44M 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 88M 0 88M 0% /run/shm
/dev/mmcblk0p1 75M 27M 48M 36% /boot
[email protected]:~#

Is one of those first 2 entries incorrect? and if so, what can I do to correct this? Thanks for the help.
RickB1010

it should be saying just under 8gb for rootfs and same for /dev/root if you are using 8gb card. I take it that you have run expand filesystem option.

Hi alexal. Thanks for reply. Yes in raspi-config one of the options is to use the entire SD card and I have selected it 3 times and then rebooted as per instructions but same result.

Have you tried a different card? that’s what I would do - I’ve read on other forums that some cards play up.

Well I can do that … but it is a working system with a lot of stuff set up and working so I was hoping to solve this by linux commands.

It’s just to check that new card deploys full usage, if it does, you know that there’s an issue with it; you can do a full backup on old card and restore on new one if you wish. you will always have copy of original card.

I have done a successful backup using win32diskimager, The image was indeed 8Gb and windows diskmanager reports 2 partitions a small Fat32 and a Linux 8Gb (approx.). Does this mean that all is well? Maybe this is supposed to be almost 8GB when installed. I guess I was confused because df -h reports
rootfs 3.6G 3.0G 461M 87% /
/dev/root 3.6G 3.0G 461M 87% /

That looks like only 4GB (approx.)
Why does it show an entry rootfs as well as an entry /dev/root? are they both referring to the same space. Again - I’m really sorry but I am very new to this. Thanks.

It was a defective SD card. I purchased a new class 10 Kingston 16GB card and it installed properly and is behaving properly. Thank you for the help - you were spot on.

Hi Rick,
You successfully installed the FreePBX on PI.
I would like to do the same. Is there any step-by-step install guide I can follow?

I greatly appreciate your help.
Rajap

Rajap

Have you tried searching “install freepbx on raspberry pi?”

alan_mousty:
Thanks. I got the links.
Rajap

Have you tried RasPBX? http://www.raspberry-asterisk.org/