FreePBX migration from 2.10 to 13 - Direct Dial Voicemail no longer working


When attempting to direct dial to voicemail using * I receive a busy signal. If I hit Transfer > Blind Transfer > * the phone says back “This feature is not available”.
I attempted to use the extensions_additional.conf from the old system since it contained what looked like the dial plans for the direct dial voicemail where as the new servers file does not contain nearly as much.

I am unsure if I need to do a dialplan reload for the new file to be read or if there is some difference in the system regarding how direct dial voicemail is handled.

This is found in the log when you attempt to direct dial any extension:

[2016-04-28 11:16:54] NOTICE[38902][C-0000007d] chan_sip.c: Call from ‘294’ ( to extension ‘*293’ rejected because extension not found in context ‘from-internal’.

Do you have the feature code enabled and set to “*” in Feature Code Admin? Are all of your modules fully up to date?

Hello - thank you for your reply!

I checked the Feature Codes and here is what I have:

In-Call Asterisk Attended Transfer - *2
In-Call Asterisk Blind Transfer - ##

I changed the Blind Transfer to * instead of ## but it still gives the same errors. The phones are Polycom 650 units if that helps. Please let me know if you’d like me to post any of the config files. Thanks again for the help - this is an odd one!

Also, with the modules question. I updated everything to the latest except for freepbx - I was unable to to 13.0.27 i believe it is. Currently on 13.0.120 so a module or two wouldnt update due to that.

Never said anything about transfers. Please reset those. Look for voicemail in feature code admin.

Great - I reverted the option I changed back to its default.

Under voicemail I have:

Dial Voicemail *98
My Voicemail *97

So Dial Voicemail should be changed to just *?

You should also have direct dial voicemail


Interesting. I do not have that in my feature list. I only have Dial Voicemail and My Voicemail - am I missing a module?

fwconsole ma install voicemail

^ run that in the CLI

That did it - the prefix is now showing. I’ll be able to test shortly - i’ll let you know the results. Should I run a reload command of sorts or is that change live? Thanks for all the help!

Run a reload. It’ll need to generate the dialplan

Thank you very much - all is working well now. You guys rock!