Freepbx installation gives "Error! Invalid Database Permissions. The error was: could not find driver"

I’m following this guide:
https://wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+Debian+8.1

But on Freepbx installation step i’m getting:

[email protected]:/usr/src/freepbx# ./install -n
PHP Warning:  Declaration of FreePBX\Install\FreePBXHelpCommand::setCommand(FreePBX\Install\FreePBXInstallCommand $command) should be compatible with Symfony\Component\Console\Command\HelpCommand::setCommand(Symfony\Component\Console\Command\Command $command) in /usr/src/freepbx/installlib/installhelpcommand.class.php on line 15
Assuming you are Database Root
Checking if SELinux is enabled...Its not (good)!
Reading /etc/asterisk/asterisk.conf...Done
Checking if Asterisk is running and we can talk to it as the 'asterisk' user...Done
Preliminary checks done. Starting FreePBX Installation
Checking if this is a new install...Yes (No /etc/freepbx.conf file detected)
Database Root installation checking credentials and permissions..Error!
Invalid Database Permissions. The error was: could not find driver

What did i missed?
I tried to search in community, bit i found nothing.

Any suggestions?
Regards,
Nufay.

apt-get install php-mysql

fixed this error, now i’m feeling myself like an idiot, cause of my inattention…
So this problem is solved.

Thanks, works like a charm!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.