FreePBX | Register | Issues | Wiki | Portal | Support

Freepbx infostrada


(Nexet) #1

hi guys, sorry for the mistakes I’m Italian.
I have my provider that I can not run it on freepbx, I have used the same data on zoiper and they work great.
I configured patton and others on freepbx but this creates problems for me.

        proxyServer voip.libero.it 5060 UDP
        registrarServer voip.libero.it 5060 UDP
        userAgentDomain sip.infostrada.it UDP
        outboundProxy voip.libero.it 5060
        authUsername    xxxxxxxxxx
        authPassword     xxxxxxxxxx

my trunk sip:
username=xxxxxxxxx
type=friend
secret=xxxxxxxxxx
qualify=yes
outboundproxy=voip.libero.it:5060
host=sip.infostrada.it

where am I wrong?


(Dave Burgess) #2

Show us the piece of the logs of your system trying to connect. That should help.

Some providers do not allow Asterisk to connect to their system. They look at the “type” field and if it is Asterisk in any form, they block the connection. Call as ask their tech support if you can connect as Asterisk system and if they say “No”, this might be your problem.


(Nexet) #3

hi , it actually connects, but I can not get in
I tried a colleague with zoiper and it works well, so I suppose if zoiper works it should also go asterisk no?

for the log I visualize the full, I can not identify the connections, could you help me?


(Dave Burgess) #4

No.

Many providers allow phones (soft or hard) to connect to their services, but do not allow Asterisk to connect. When the connection is made, the system tells your provider what kind of a phone you are using. Asterisk replies with “Asterisk” and they terminate the connection.

There must be an error message in the logs when you try to connect the trunk to the provider. If there’s isn’t, your trunk configuration is probably incorrect. I’d start by replacing the FQDN with the IP address of the server. Also, which SIP driver are you using? Chan_SIP or PJ-SIP?


(Nexet) #5

the ip of the host ie sip.infostrada.it I can not connect (not even zoiper) if I enter the dns yes, although the ping responds that ip, the dns and only reachable for those who have the infostrada line.

to find in the log the error that filter I can use? if I enter connection I find only:

[2019-01-08 17:42:19] VERBOSE[2315] asterisk.c: Remote UNIX connection
[2019-01-08 17:42:19] VERBOSE[20495] asterisk.c: Remote UNIX connection disconnected
[2019-01-08 17:42:19] VERBOSE[2315] asterisk.c: Remote UNIX connection
[2019-01-08 17:42:19] VERBOSE[20500] asterisk.c: Remote UNIX connection disconnected
[2019-01-08 17:42:19] VERBOSE[2315] asterisk.c: Remote UNIX connection
[2019-01-08 17:42:19] VERBOSE[20502] asterisk.c: Remote UNIX connection disconnected
[2019-01-08 17:42:19] VERBOSE[2315] asterisk.c: Remote UNIX connection
[2019-01-08 17:42:19] VERBOSE[20504] asterisk.c: Remote UNIX connection disconnected
[2019-01-08 17:42:28] VERBOSE[2315] asterisk.c: Remote UNIX connection
[2019-01-08 17:42:28] Asterisk 13.22.0 built by mockbuild @ jenkins7 on a x86_64 running Linux on 2018-07-25 22:30:39 UTC


(Nexet) #6

ok I solved almost, the asterisk works, receive calls and send calls, I only have a problem when I receive the asterisk time saying:
the number you typed is not in use.


(Dave Burgess) #7

Say it in Italian - I don’t think that translated right.

I’m going to guess that the number you are sending is not in the format infostrada is expecting. You are probably going to have to adjust the number in your outbound route or trunk.

Details help us to have to guess. Examples help the feeble amongst us to understand.


(Nexet) #8

sorry :
se provo a chiamare freepbx da un cellulare , freepbx risponde con una voce dicendo
il numero digitato non è in uso.

invece le chiamate in uscita da freepbx funzionano correttamente .


(Dave Burgess) #9

If your call cannot be completed, it usually means that either your registration is wrong or you are trying to use an Inbound Route with your phone number and the number the phone company is sending is not the same.

To test this, remove the number from the Inbound DID in the Inbound Route and set it up as an any/any route.

Se la chiamata non può essere completata, in genere significa che la registrazione è errata o se si sta tentando di utilizzare una rotta in entrata con il proprio numero di telefono e il numero che la compagnia telefonica sta inviando non è lo stesso.

Per verificare ciò, rimuovere il numero dal DID in entrata nella rotta in entrata e configurarlo come una qualsiasi / qualsiasi rotta.


(Nexet) #10

il messaggio è “il numero digitato non è in uso” dato da freepbx , quindi la chiamata arriva a freepbx , come se freepbx non avesse la rotta in ingresso impostata , ma lo è.
la rotta in ingresso è già impostata come DID any e CID any .

the message is “the number entered is not in use” given by freepbx, so the call arrives at freepbx, as if freepbx did not have the input route set, but it is.
the incoming route is already set as DID any and CID any.


(Dave Burgess) #11

The file /var/log/asterisk/full will show the error from the incoming call.


(Nexet) #12

ecco cosa succede quando ricevo la chiamata:

[2019-01-08 21:50:12] VERBOSE[2568][C-00000007] netsock2.c: Using SIP RTP TOS bits 184
[2019-01-08 21:50:12] VERBOSE[2568][C-00000007] netsock2.c: Using SIP RTP CoS mark 5
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:1] GotoIf(“SIP/10.223.59.9-00000008”, “1?setlanguage:checkanon”) in new stack
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx_builtins.c: Goto (from-sip-external,s,2)
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:2] Set(“SIP/10.223.59.9-00000008”, “CHANNEL(language)=it”) in new stack
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:3] GotoIf(“SIP/10.223.59.9-00000008”, “1?noanonymous”) in new stack
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx_builtins.c: Goto (from-sip-external,s,5)
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:5] Set(“SIP/10.223.59.9-00000008”, “TIMEOUT(absolute)=15”) in new stack
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] func_timeout.c: Channel will hangup at 2019-01-08 21:50:27.155 UTC.
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:6] Log(“SIP/10.223.59.9-00000008”, "WARNING,“Rejecting unknown SIP connection from 151.6.106.105"”) in new stack
[2019-01-08 21:50:12] WARNING[12193][C-00000007] Ext. s: “Rejecting unknown SIP connection from 151.6.106.105”
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:7] Answer(“SIP/10.223.59.9-00000008”, “”) in new stack
[2019-01-08 21:50:12] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:8] Wait(“SIP/10.223.59.9-00000008”, “2”) in new stack
[2019-01-08 21:50:14] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:9] Playback(“SIP/10.223.59.9-00000008”, “ss-noservice”) in new stack
[2019-01-08 21:50:14] VERBOSE[12193][C-00000007] file.c: <SIP/10.223.59.9-00000008> Playing ‘ss-noservice.ulaw’ (language ‘it’)
[2019-01-08 21:50:19] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:10] PlayTones(“SIP/10.223.59.9-00000008”, “congestion”) in new stack
[2019-01-08 21:50:19] VERBOSE[12193][C-00000007] pbx.c: Executing [s@from-sip-external:11] Congestion(“SIP/10.223.59.9-00000008”, “5”) in new stack
[2019-01-08 21:50:24] VERBOSE[12193][C-00000007] pbx.c: Spawn extension (from-sip-external, s, 11) exited non-zero on ‘SIP/10.223.59.9-00000008’
[2019-01-08 21:50:24] VERBOSE[12193][C-00000007] pbx.c: Executing [h@from-sip-external:1] Hangup(“SIP/10.223.59.9-00000008”, “”) in new stack
[2019-01-08 21:50:24] VERBOSE[12193][C-00000007] pbx.c: Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/10.223.59.9-00000008’


(Dave Burgess) #13

You don’t have a trunk set up for this IP address. Are you using PJ-SIP or Chan-SIP for your external connections?


(Nexet) #14

chan_SIP


(Nexet) #15

I wonder, why give outgoing calls work?
why do not I receive call but call arrive at freepbx and responds with the message “the number entered is not in use” ?

this means that freepbx receive calls.
if I disable the trunk and I call the line falls.
if i enable the trunk , freepbx responds with the message .


(Dave Burgess) #16

incoming and outgoing calls are only related because they use computers. For all other purposes, it helps to think of them as completely unrelated.

Since you are using Chan_SIP, you need to set up one trunk for each IP address associated with the hostname of the provider. This is just the way that works.

For outgoing calls, they have services set up at every IP address that the address resolves to, so the outgoing calls connect just fine.


(Nexet) #17

so I duplicate an equal trunk but insert ip shown above?


(Nexet) #18

I noticed that I have 2 trunk online, maybe in the configuration of my trunk already I set the double trunk?

n.b. l’ip 151.6.106.105 is outbound proxy --> voip.infostrada.it


(Dave Burgess) #19

Simple answer, yes.


(Nexet) #20

dove sbaglio ? :frowning: