FreePBX HTTPS with High Availability

How can I config https with freepbx HA? I make certificates and upload it to apache config.
When I write I use https.
When I write I receive a mistake (see on picture).

How can I redirect from 80 port to 443 port?

Your protocol scheme needs to match. The important part isn’t the port, it’s the HTTP or HTTPS. In your case, HTTPS:// or HTTPS://

When I write I can connect to FreePBX via HTTPS.
When I write I can not connect to FreePBX via HTTPS.

How can I redirect all requests from port 80 to port 443 (Or how can I use HTTPS connection to all the time?)

How can I redirect all requests from port 80 to port 443 (Or how can I use HTTPS connection to all the time?)

Use a Redirect header on the index page on the base web server? Note that this isn’t an Asterisk or FreePBX problem - this is really super basic HTML stuff.

HTTPS automatically connects to port 443 (just like the naked HTTP connects to port 80).

When I change httpd.conf I can not redirect to HTTPS.
When I make changes in .htaccess I connect to HTTPS, but when I upgrade FreePBX, I lost my settings.

The easiest way to redirect https is to use the router to forward external port 443 to port 80. I prefer not to modify httpd.conf as much as possible…

You can’t just change the port - you have to change the protocol too.

There are six cases available, two of them don’t work:

https://x.x.x.x:80/ XXXXX
http://x.x.x.x:443/ XXXXX

If you change the port from 80 to 443 in the router, you end up with http protocol going to port 443. This doesn’t work. It causes exactly the same problem you just tried to not have.

One more time - go to to get the information you need. I would recommend using the “mod_rewrite” module in the Apache server to solve your problem. If you are really opposed to changing the apache config file, check out the PHP rewrite programs that you can install as the Index.php in your base webpage.

Finally - THIS ISN"T A FREEPBX ISSUE! This is some of the most basic web server stuff there is. So, to be clear, I’ve told you twice how to solve this problem. I did the Google search I told you to use and the first 300 articles all end up telling you the same thing. I’m done.