FreePBX - Grandstream Extension Calls Not Working on VPN

Hi guyz I have 2 Cisco Routers - RV042(Site A) and RV082(Site B). And it is configure as gateway to gateway in configuration…working with files and computer servers both can access with each other and it has no problem…

Site A (im using grandstream GXW4024) - my freepbx distro server is in this site…
Site B (im using grandstream HT503) - I have one extension line here so I can call to one of the extension in Site A.

Note: Both grandstream are provision in freepbx server.

My problem is when one of the extension of Site A will call to the extension in Site B…the Site A cannot hear anything but Site B can hear the voice of Site A.

Please help me with this one guyz…where did I go wrong? Is their a port that I need to portforward for the routers?


It seems like the RTP isn’t flowing properly. Are you doing NAT or just routing? Any firewalls probably blocking those ports? You want to focus on the packet from Site B to Site A for any of the above cases…

Sounds indeed like a RTP issue but we’ve had the same problem with the Cisco RV82 series and after weeks of testing we found the problem in the MTU value (you have a different packet size when using a VPN).

If location B is using a different subnet, make sure that it is included in the Local Networks setting (Asterisk SIP Settings).

Sanjayws…we are just routing and no NAT…What specific port do you mean that was block maybe in our firewall?

I really appreciate your response…thanks

James83 what MTU value do you set in your RV82 router? does it mean that both router used in VPN must have the same MTU value?


Hi Stewart1, yes it has a different subnet since I am using VPN… My question is where can I include my local network settting / asterisk sip settings of Freepbx?

Typically you would want to open ports UDP 10000 to 20000 by default. Unless you’ve changed that.

Also, go to the GS box webpage and see what ports they use for RTP, open those too…

Yes in SIP settings localnet. It is very important because networks referenced in this list are EXCLUDED from NAT processing. Since a VPN Layer 2 you don’t need NAT, it’s a routed/connected network.

Sir, excuse me for my ignorance…I am still new to this system… where can I find that SIP settings localnet? and what do I need to do about it?


In the SIP settings module. There are fields to declare all connected networks.

See SIP setting documentation under modules in our wiki

@SkykingOH…thank you so much…it solves my problem…