FreePBX Framework update stuck

Yesterday I tried to install updates since in Dashboard I get a message that fixes for security vulnerabilities are available with FreePBX Framework Update among them. The update seems to run but when it comes to the point where it says “Updating version information” the update hangs and does not complete. What can I do about that? The installed Framework version is an it tries to update to

Can you try applying the update from the command line, using “fwconsole ma update framework” ? It might show an error that you can share here for further troubleshooting.

There was a Framework update error a couple of months ago where you couldn’t do a huge jump because one of the modules was required for an update and the update would just puke when you tried. There was a “Class” error in the code and you had to install a specific version of the Framework module to get past it.

Could be the same problem. @wmoon is right that you should log into the console and try it from the Unix prompt. The error will tell us what you need to do next.

@wmoon great tip! Framework could be updated using the command line. After that all the other modules could be installed via the GUI.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.