FreePBX Flowroute config

Hi all,
I have reached out to Flowroute for assistance in getting my FreePBX (Asterisk 13.22.0 FreePBX 14.0.5.4) working with Flowroute.

The config template they sent me is:
General:
Username = techprefix
password = password
auth is outbound
registration is send
sip server is your prefered flowroute registration domain from your account
port is 5060
context is from-pstn
transport is 0.0.0.0-udp

Advanced:
DTMF is RFC4733
Match(permit) = 147.75.60.160/28, 34.210.91.112/28, 34.226.36.32/28, 147.75.65.192/28
Support path yes
rtp symmetric yes

The config I am using is in ‘sip Settings’ is:
disallow=all
username=hidden
type=friend
secret=hidden
insecure=port,invite
host=sip.flowroute.com
fromdomain=sip.flowroute.com
dtmfmode=rfc2833
context=from-trunk
canreinvite=no
allow=ulaw

Can someone please tell me where I am going wrong as Flowroute says that there are no connections.

For starters, sip.flowroute.com will be decommed in 2 days. I’ll see what I can pull from a working config tomorrow :slight_smile:

1 Like

The best way to go is to use PJSIP. It looks like you have the configs for both. So I’m not exactly sure what you’re trying. Also, yes, make sure you use one of their new PoPs, they’re trying to put as many people there as they can, and they’re more reliable anyways.

Take a look at this guide for the best way to set up your pjsip trunk, assuming your PBX has a static ip.

Are you a 100% sure of that? The only thing being decommissioned in two days it the California edge proxy. That would be sip-la1.flowroute.com and sip-ca1.flowroute.com.

1 Like

I was 100% sure, now less so that you bring it up. I’ll reach out to support to confirm. I was under the impression that it would be affected based on the in-account notification.

I ended up occupied most of the day and wasn’t able to pull the working config I have, but it seems that Matthew beat me to the punch :slight_smile:

Thanks for your replies everyone.

Just to confirm I am trying to get chan_pjsip working. I have changed the port to listen on 5160.

SIP I will be using is us-east-nj.sip.flowroute.com

Overkill, I’d really appreciate it if you could post your chan_pjsip (minus username and password of course).

Having just gone through the process of moving to one of the new FlowRoute POPS, you must have a PJSIP trunk, not a SIP trunk. I think from your config stuff you are trying to do it by making a SIP trunk.

I did not have PJSIP enabled on my system. This is the process I used.

1). Move everything using SIP to port 5160. Change Asterisk SIP Settings > Chan SIP Settings. Lots of info on this forum. I am continuing with SIP for my extensions for now.
2). Enable PJSIP in Settings > Asterisk SIP settings. Since I am still using SIP I set it to Both.
3). Under Asterisk SIP Settings > Chan PJSIP Settings make sure that PJSIP is set to 5060.
4). Do an fwconsole restart (or reboot)
5). Create a PJSIP Trunk. Do what Flowroute states.

I had a No Auth error and also made a stupid mistake. The No Auth cleared unless the error was triggered somehow by my goof. See the good how-to at

https://community.freepbx.org/t/how-to-flowroute-trunk-with-proper-use-of-ip-auth-and-new-pops

Since I have a dynamic IP (hasn’t changed in a year but not paying for static), I did not use any IP Auth or other safeguards available through flowroute. Just SIP Registration. Make certain you go to your dashboard and Connection and select your preferred POPS.

PJSIP TRUNK > General

Username = your techprefix
password = your password
auth is outbound
registration is send
sip server is your prefered flowroute registration domain from your account , i.e us-east-nj.sip.flowroute.com
port is 5060
context is from-pstn
transport is 0.0.0.0-udp

Advanced:
DTMF is RFC4733
Match(permit) = 147.75.60.160/28, 34.210.91.112/28, 34.226.36.32/28, 147.75.65.192/28
Support path yes
rtp symmetric yes

Everything else should be default.

Remember: The default bind ports for FreePBX have changed. Please keep this is mind while configuring your devices. You can change this in SIP Settings. CHAN_PJSIP is: 5060, CHAN_SIP is: 5160.

ALSO, and very important, if you have an external firewall/router or just a router, make certain that ports are properly opened and forwarded to your pbx. This includes all of the IPs in the Match line above.

Thanks for your help John.

I have now been able to connect FreePBX to Flowroute.

All I need to do now is get a softphone that works with PJSIP as X-Lite doesn’t want to dial out. (Might be my dial pattern as well).

For now, try keeping X-Lite on SIP. I am pretty sure that under its settings you can specify port 5160. And under sip server address of X-Lite enter the IP of your FreePBX server, I.E., enter XXX.XXX.XXX.XXX:5160. Your fpbx server’s IP address with a colon and 5160… :5160

No, don’t keep X-Lite on SIP. Get rid of X-Lite or sometime between March and May of 2019 it will just stop working anyways. Counterpath is removing all systems/servers for the X-Lite program and that will basically kill any X-Lite apps from working since they can’t phone home.

So instead of X-Lite, what softphone do you all recommend?

Bria. It’s $9.99 a year.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.