FreePBX Firewall on v13

I recently installed a fresh v13 (on CentOS 7) and was overjoyed to see that FreePBX has added a “responsive” firewall approach. This is something I had been doing on my own with a kludge for some time. Best feature yet!

I noticed it required sysadmin to install. I wasn’t able to find any sysadmin under yum but I was able to force the install in FreePBX modules.

Well, it turns out, that was a huge mistake and I’m over my head. Now when I attempt to go to the FreePBX HTTP admin interface, all I get is:

0 System Admin Copyright 2016 by Schmoozecom, Inc., All rights reserved By installing, copying, downloading, distributing, inspecting or using the materials provided herewith, you agree to all of the terms of use as outlined in our End User Agreement which can be found and reviewed at

Is there any way to remove this sysadmin module via command line so that I can get my FreePBX back? If so, is there a tutorial on how to get FreePBX Firewall intalled on FreePBX v13 on CentOS v7 somewhere (I’ve googled plenty but didn’t find anything that related to what I’m seeing, which states I’m missing the sysadmin dependency)?

Thank you in advance!


fwconsole ma uninstall sysadmin

You can learn a lot more about fwconsole by reading this wiki page.

I am guessing that the reason you were not presented the option of installing sysadmin, is because your system won’t support it. Are you using the FreePBX Distro?

Thank you! I should have mentioned that I tried that and it didn’t have any effect. I just assumed that there was more to it.

After Googling and more testing, I just decided to re-install everything from scratch. I installed CentOS 7 + Asterisk 13 + FreePBX

This time I happened to notice that Firewall is not installed because it’s only compatible with RHEL 7 and RHEL 7.

I had hoped CentOS 7 would qualify, but it sounds like this is not possible?

CentOS V7 effectively is RHEL 7 without the support and branding.

I doubt your going to have much luck getting FreePBX 13 to work properly on CentOS V7. I’m pretty sure they are working on V7 compatibility with FreePBX 14.

Why not just install the distro? It installs FreePBX’s version of CentOS V6.


CentOS V7 effectively is RHEL 7 without the support and branding.

That was exactly what I thought. However, after two attempts not being able to get the FreePBX firewall running on CentOS 7, I began to think that @xrobau may have explicitly meant RHEL and not CentOS for some reason.

Why not just install the distro? It installs FreePBX’s version of CentOS V6.

That was my first attempt. Unfortunately I’m installing on a VPS and for some reason there were issues installing the latest v14 version on a VPS which @xrobau added to the tracker.

I figured I’d manually install on my own for now, then update to the v14 release.

…Just to confirm, is it official, then, that FreePBX Firewall should work on CentOS 6/7 as well, and that the issues I’ve run into with FreePBX v13.0.188.8 running on CentOS 7, are unexpected?

The problem you are running into is that the sysadmin module has additional RPM requirements in order to function properly, which we document for our current stable distro at

@GameGamer43 -
Thank you so much. I can’t believe how long I searched and yet never turned-up this info. This is exactly what I needed, thank you!

Argh… I spoke to soon!

Once I add the commercial repository as directed by that page:
wget -P /etc/yum.repos.d/ -N

From that point yum has issues:

One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this: <…snip…>

I spent the night searching and testing a number of things that caused me problems. Despite all of that, I was never able to find anything that allows me to ad the schmoozecom repository without hosing my yum at that point.

Could it be an issue with CentOS 7 … or the other CentOS repositories I’m using by default?

The issue is that the documentation is for our latest stable distro which is compatible with EL 6 not 7. The distro we have in alpha is compatible with EL7 and includes everything you’d need to get up and running. You can find the current ISO for our Alpha distro at

Thank you. I’d definitely have gone that route if I could, but…

I had wrote above, I can’t install the turnkey distro because it has issues where it won’t install on my VPS server.

@xrobau had me setup an issue in the tracker for this.

I know the docs are wrong, but is there any way to add a schmooze repository that will work with RHEL/CentOS 7?

Because I have found no way to install the Sangoma distro on CentOS 7, I’ve also tried a few moe versions of the CentOS 6 and 6.6 on my VPS.

In every event I cannot get the distro to install. It always seems that it cannot find my local VPS storage (SSD-based).

Here’s an example of the error I’ll reach after the initial install process “No usable disks have been found.”

@RKM, If your host doesn’t support the distro, you can always follow the instructions about installing FreePBX manually, which you can find at After doing that you can then follow the wiki article about installing commercial modules on manually installed systems which can be found at

@GameGamer43 Thank you. That was the gist of this post, I had already done it manually and spent many hours trying to get variations of your second link to work for the commercial modules.

However, the problem was that evidently the commercial module dependencies / that link you quoted, no longer work on CentOS 7.

Thank you for the reply.

That’s correct. I realise that this is a terrible answer, but, there’s no way to do what you want to do (easily) at this point. That’s 100% my fault because I haven’t had time to do it, and I’ve had to come back to Australia for a funeral. However, next week I should have this sorted out - and a beta2 ISO if you want to go that route directly.