FreePBX Firewall "could not get banned list"


(Mmgg) #1

After installing the firewall module on FreePBX 14 I cannot get it to run. The wizard always crashes with the error “could not get banned list”. I read that the FW requires sysadmin rpm to be up to date. I’m not quite sure if I understand what sysadmin rpm is but yum update sysadmin doesn’t update anything and yum list sysadmin shows
sysadmin.noarch 5.6-5.6.28.sng

So I assumy that the sysadmin module is up to date.

I also tried fwconsole chown which didn’t help.

Any ideas what’s wrong here?

Thanks very much!
Michael


(Itzik) #2

Is this the FreePBX distro, if so, why not install FreePBX 15?

Try the following:

fwconsole ma upgradeall
fwconsole chown
fwconsole reload
yum update -y
reboot

(Mmgg) #3

Why would I install FreePBX 15? This is marked as stable.
I have a feeling that FreePBX is really poor quality so I don’t trust any upgrade.


(Itzik) #4

15 is the latest stable, 13 and 14 will likely become EOL once 16 becomes stable.

The commands I provided are module and rpm updates, it won’t update you to 15.
Anywho, if you don’t trust FreePBX, then why install it? Just so you can troll us?


(Lorne Gaetz) #5

If you are setting up a new system now, it should be using FreePBX 15. Your sysadmin rpm is out of date, current version from 14 is:

[root@ucc-74657009 ~]# yum list sysadmin
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
Installed Packages
sysadmin.noarch                  5.6-5.6.47.sng                   @anaconda/2011

(Mmgg) #6

I ended up setting up a new system on FreePBX15. Here the firewall is working.

I still have that old system running and I wonder how I can get the latest sysadmin rpm.

[root@pbx2 ~]# yum update sysadmin

Loaded plugins: fastestmirror, langpacks, replace
Loading mirror speeds from cached hostfile
epel/x86_64/metalink | 33 kB 00:00:00

  • base: ftp.nluug.nl
  • epel: ftp.nluug.nl
  • extras: ftp.nluug.nl
  • rpmfusion-free-updates: ftp.nluug.nl
  • updates: mirror.nl.datapacket.com
    base | 3.6 kB 00:00:00
    epel | 4.7 kB 00:00:00
    extras | 2.9 kB 00:00:00
    ius | 1.3 kB 00:00:00
    nodesource | 2.5 kB 00:00:00
    rpmfusion-free-updates | 3.7 kB 00:00:00
    updates | 2.9 kB 00:00:00
    (1/3): epel/x86_64/group_gz | 96 kB 00:00:00
    (2/3): epel/x86_64/updateinfo | 1.0 MB 00:00:02
    (3/3): epel/x86_64/primary_db | 6.9 MB 00:00:07
    No packages marked for update

(Mmgg) #7

Ok, the problem is still not quite solved by moving to FreePBX 15. When I open Connectivity/Firewall it says Firewall is enabled but when I click on Status I get an exception “Firewall is not running”.

Seems like i’m still missing something :/.


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.