Freepbx Error after deleting trunks


I have freepbx 15 installed and I added a trunk and wanted to delete the old trunks however after deleting the old trunks when clicking apply I am getting the below error.

Any ideas?


In extensions.class.php line 197:

died in splice macro-dialout-trunk s

Exception trace:
() at /var/www/html/admin/libraries/extensions.class.php:197
extensions->splice() at /var/www/html/admin/modules/allowlist/
allowlist_hookGet_config() at /var/www/html/admin/libraries/BMO/DialplanHooks.class.php:95
FreePBX\DialplanHooks->processHooks() at /var/www/html/admin/libraries/Console/Reload.class.php:318
FreePBX\Console\Command\Reload->reload() at /var/www/html/admin/libraries/Console/Reload.class.php:91
FreePBX\Console\Command\Reload->execute() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Command/Command.php:255
Symfony\Component\Console\Command\Command->run() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:960
Symfony\Component\Console\Application->doRunCommand() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:255
Symfony\Component\Console\Application->doRun() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:148
Symfony\Component\Console\Application->run() at /var/lib/asterisk/bin/fwconsole:163

reload [–json] [–dry-run] [–skip-registry-checks] [–dont-reload-asterisk]

did you log into the CLI and issue the fwconsole reload command?

Already tried and pasted the error I got from the cli. I couldn’t post 2 screenshots as I am still a new member and I copy and pasted the results.

This is an allowlist issue, which should be resolved in allowlist version 15.0.3

Is the module out of date?

Allowlist is the latest version

Disabling or uninstalling allow list should resolve, but it would be great to know how to repro this so it can be fixed.

Reproduced, ticket here

Suggested fix in ticket, needs testing. Attention @mitchmitchell

I’ve added the fix to my current working copy, I’ll create a pull request later this week.

1 Like

I have found out my issue, in the outbound route the trunk sequence for matched routes was empty.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.