FreePBX Distro Update - Need more space on /boot

Hi All,

Quick question, I am trying to update my FreePBX Distro version using the automatic system (/usr/sbin/sysadmin_update_system) but it says that there is not enough space on the /boot partition.

Transaction Check Error:
installing package kernel-2.6.32-431.el6.x86_64 needs 14MB on the /boot filesystem

Error Summary

Disk Requirements:
At least 14MB more space needed on the /boot filesystem.

What can I delete to make the room?

[[email protected] boot]$ du -a
2 ./grub/device.map.rpmsave
13 ./grub/iso9660_stage1_5
36 ./grub/splash.xpm.g
1 ./grub/menu.lst
13 ./grub/minix_stage1_5
13 ./grub/vstafs_stage1_5
2 ./grub/grub.conf.old2
15 ./grub/xfs_stage1_5
2 ./grub/device.map
2 ./grub/splash.xpm.gz
14 ./grub/jfs_stage1_5
15 ./grub/e2fs_stage1_5
2 ./grub/grub.conf
2 ./grub/grub.conf.old
2 ./grub/grub.conf.rpmsave
16 ./grub/reiserfs_stage1_5
2 ./grub/stage1
13 ./grub/ufs2_stage1_5
1 ./grub/menu.lst.rpmsave
13 ./grub/ffs_stage1_5
14 ./grub/fat_stage1_5
125 ./grub/stage2
320 ./grub
2 ./.vmlinuz-2.6.32-358.14.1.el6.x86_64.hmac
103 ./config-2.6.32-358.14.1.el6.x86_64
247 ./efi/EFI/redhat/grub.efi
249 ./efi/EFI/redhat
251 ./efi/EFI
253 ./efi
10 ./boot/grub/minix_stage1_5
12 ./boot/grub/xfs_stage1_5
1 ./boot/grub/device.map
11 ./boot/grub/jfs_stage1_5
11 ./boot/grub/e2fs_stage1_5
1 ./boot/grub/default
12 ./boot/grub/reiserfs_stage1_5
1 ./boot/grub/stage1
1 ./boot/grub/installed-version
10 ./boot/grub/fat_stage1_5
143 ./boot/grub/stage2
214 ./boot/grub
215 ./boot
3952 ./vmlinuz-2.6.32-358.14.1.el6.x86_64
2353 ./System.map-2.6.32-358.14.1.el6.x86_64
du: cannot read directory `./lost+found’: Permission denied
13 ./lost+found
15546 ./initramfs-2.6.32-358.14.1.el6.x86_64.img
183 ./symvers-2.6.32-358.14.1.el6.x86_64.gz
22942 .
[[email protected] boot]$

Thanks,
edooze.

Here is what my system looks like -

[r[email protected] boot]# pwd
/boot
[[email protected] boot]# du .
320	./grub
251	./efi/EFI/redhat
253	./efi/EFI
255	./efi
13	./lost+found
23751	.
[[email protected] boot]# df .
Filesystem     1K-blocks  Used Available Use% Mounted on
/dev/sda1         297485 33964    248161  13% /boot

Thank you!

After more investigation, it turns out that there isn’t enough space on the /boot partition.

I am running FreePBX in a VM with VMWare player, and it only creates a 50MB /boot partition.

[[email protected] ~]$ df /boot
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/sda1 49405 32129 14717 69% /boot

I am using this link to (hopefully) resize the partition:

Hopefully this post will help someone else if they come across this issue.

Hi, why not limit the number of Kernels kept by the system in the /boot partition instead of resizing it?

AKA: Freeing the /boot partition (limited space) by removing unused Kernels is (IMHO) a way far more secure than resizing the boot partition and it involves just few commands on system’s CLI.

References here.

1 Like

Good reference on limiting kernels! I’ve needed that in the past.

It looks like the poster has a single kernel on his /boot partition and can’t install a second.

Yes, I’ve tried limiting the kernels stored (have limited it to 4) but there was only one there, so it didn’t help.

In hindsight, I ended up booting from a LiveCD and changing partition sizes with GParted. It was much easier, and worked a treat.

Looks strange that a FreePBX Distro fresh install (not FreePBX on a stock CentOS Distro install) creates a default size /boot partition so small that it isn’t able to accomodate - at least - two Kernel images at a point its size prevents you to perform a scripted system update.

Was an install with custom (disk) layout or you accepted the default suggested one?

That’s exactly what I thought, which is why I posted in this forum before just changing the partition sizes myself. After more research it seemed that a typical partition boot size was around 600MB, rather than the 50MB, so I assumed it was a mistake and changed it.

I did manage to find another post that said the VMWare ‘Auto Installer’ might automatically set the /boot partition size to 50MB, and though I’m fairly sure I haven’t ever used an auto installer, that’s the only thing I can think it might have been.

Wait. If you installed the FreePBX Distro (track 5 or 6, no matter which one) providing the ISO file to your VMware VM generator (and previously you had to define at least one virtual disk - and its raw size - to be used by that new VM) then the FreePBX Distro installer (Anaconda) should have given you two options to define system partitioning on the provided (virtual) disk: a default (automatic) layout which uses LVM2 or a custom one (with manual disk layout, with or without LVM2). I’m not sure Anaconda let VMware to decide the boot partition’s size once (or before) it begun the installation process.