FreePBX Distro - CSIPSimple - No Outgoing Calls on LAN

Instead of flooding my first post with logs and config files that may not be even remotely helpful, I’m gong to pose my question and then will provide other data on request :slight_smile:

I setup a FreePBX box this week and configured it with my SIP and am using my Android phone with CSipSimple to make and receive calls.

I can complete inbound and outbound on 3G/LTE, and any wireless access I have tried, except my own. I can receive calls on the same network as my FreePBX box, but not make them. When I try, the dialer acts like it’s making the call, but I get no dialing tone and the app freezes up for about 15 seconds (can’t hang up the call) until it finally ends with “408 / Request Timed out”.

I enabled SIP logging and when I attempt to make a call absolutely nothing is logged.

I changed my CSipSimple config to use my FreePBX server’s internal IP address, rebooted, and I got the same result.

THEN I changed the proxy setting to my local IP as well and the outbound calls worked fine. But then CSipSimple won’t register when off my network. (Same with proxy field left blank)

Any ideas?

Try this:

  1. Disable nat in asterisk sip setting altogether (making it ‘public’ IP)
  2. Disable nat (nat=no) at the extension/device side

Try and register internally.

Also make sure that you have the local networks setting correct in the SIP Settings.