FreePBX Distro compatible with TE133 card on DAHDI v2.7.0

Please assist. recently purchased the TE133 card to use on my PBx with FreePBX but after the installs and driver downloads faced a few issues. Upon contacting Digium I was advised the distro i have does not support the TE133 card drivers. I am on this version http://downloads.freepbxdistro.org/ISO/FreePBX-3.211.63-8-x86_64-Full-1366673197.iso

Would you know when I can expect the update that supports this card?

At this time we are not able to go to DAHDI 2.7 as wanpipe for sangoma cards can not build against DAHDI 2.7 yet. I am hoping Sangoma will have things worked out in the next couple weeks and we can start our testing of DAHDI 2.7 but since Sangoma is a Certified Partner and they have to compile against DAHDI we have to give them a little time.

If you download and install DAHDI 2.7 manually from http://www.asterisk.org/downloads/dahdi, then the FreePBX DAHDI configs module with work fine. I set this up last week on a 2.210.62-6 system with Asterisk 10.

Yes we already made the 2.10 and 2.11 DAHDI module work with the card but still working on all of our DAHDI patches.

We have to patch DAHDI for Sangoma, OpenVox and Rhino. We have the Sangoma stuff done waiting on OpenVox and Rhino who promised us this week they would get us updated patches.

I dont recommend installing DAHDI from outside the Distro as it will break updates.

Any update on this? I just got my Digium TE133 card in and I had no idea it wasn’t compatible “yet”. I don’t think I wast to install an updated DAHDI and break updates. Would love to put this into production.

Rob

Yes we have added support for DAHDI 2.7 in the 4.211.64-4 release. It will not be going in the 3.211.63-X since that is not receiving new features just bug fixes and DAHDI 2.7 introduces lots of potential issues.

Tony,
I am having the same issue where I have digium te133 and have no drivers. You state that you have added support for dahdi 2.7 in 4.211.64-4 which is my current version. How do I enable the support for 2.7?

Brian

Sorry its actually part of the 4.211.64-5 release which is not out yet but all that release does is upgrade wanpipe and DAHDI so you can from your CLI do a

yum update dahdi*

and you should be all set. I suggest rebooting after the yum update.

Tony,
It looks like only the 32bit repo has the updated version. I attempted to run yum update dahdi* on a 64 bit system(which is where I am installing the te133) and noticed there was no update available. I tried building the dahdi drivers from source and that causes the freepbx distro to kernel panic when loading the drivers. See below repo urls:

i386:
http://yum.freepbxdistro.org/pbx/4.211.64/i386/RPMS/digium/dahdi/dahdi-linux/2.7.0/
x64:
http://yum.freepbxdistro.org/pbx/4.211.64/x86_64/RPMS/digium/dahdi/dahdi-linux/

Thanks for your help Tony(or Anyone else)

I just checked and I see a 2.7.0 just fine going to that link.    I swear its been their the whole time.  I would never forget to sync a repo.

Just to confirm, with a TE133P T1 card, are both 4.211 and 3.211 compatible/supported now?

Dan

Upgraded my 3.211 and it configured fine in the GUI.

Thanks for the great Distro Tony!

Dan

yes its only in the 4.211.64 release as the 3.211.63 cant get new features anymore. It was locked to bug fixes only.

I’m pretty sure I need to install the 2.7 DAHDI to get my freepbx to see my new T133 card but i’m not sure how to use the repo listed above to get the upgraded version.

[[email protected] ~]# uname -r
2.6.32-358.2.1.el6.i686

[[email protected] ~]# asterisk -V
Asterisk 11.2.1

[[email protected] ~]# lspci -n
02:00.0 0280: d161:800a (rev 01)

[[email protected] ~]# lspci
02:00.0 Network controller: Digium, Inc. Device 800a (rev 01)

[[email protected] ~]# rpm -qa | grep dahd
dahdi-tools-2.6.2-1_centos6.i686

http://wiki.freepbx.org/display/HTGS/Upgrading+FreePBX+with+the+Official+FreePBX+Distro?src=search

Thank you! Found that there was a newer ISO at http://schmoozecom.com/distro-download.php loaded that instead and my card appeared.