FreePbx Distro Backup/Restore Questions

Hello all,

I’ve got some questions on the best way to move a system forward to a current Freepbx Distro.

Here is what I have: FreePbx Distro V 1.818.210.58-1 This version was recently EOL’d and I’ve been having some issues with a Sangoma B600 card. They would like me to update the driver to the most current version 3.5.28 and the most current version available from the repos is 3.5.27.

I want to upgrade to FreePbx Distro v 2.210.62 This is basically the same version of what is currently installed, except that instead of Centos 5.8, it is Centos 6.2.

What I tried to do is this: login to freepbx’s webgui and run backup. Admin/Backup & Restore. I created a new backup called “Now” and drug Full Backup from the right hand side of the web page to the area where you can drop it. I then did the same thing with the storage locations option by dragging Local Storage(local) over to the Storage server section. I then clicked Save and then Save and Run.

I checked the /var/spool/asterisk/backup/Now directory and there was a backup there waiting for me. The backup had the suffix of .tgz. I saved this file to another system so that I could put it on the new server when necessary.

I then pulled the hard drive and replaced it with a new one of the same size. I didn’t want to loose my current working(sort of) system.

After installing the most recent image of v2.210.62 I then did the same thing for backup. I created the same backup using the same steps so that I would have the necessary directories created (var/spool/asterisk/backup/Now). I then copied the backup image from the old install to this directory. I then noticed that the current backup does NOT create .tgz files, it makes .gz files. I couldn’t do a restore of my .tgz file. I then tried to rename it to .gz just to see what would happen and that didn’t work very well. It looked like some things might have worked out/been restored OK but then there were lots of strange characters in the restore window.

I opted to pull the new distro/drive and put my old distro/drive back in the server and get everything working again.

So, I now have a few questions about the best way to do what I was trying to do. I would like to believe that by using the same version of FreePBX (v2.10) and Asterisk (1.8.x) that I should be able to backup, switch FreePbx distros to a currently supported one and then do a restore, provided that I use the same FreePbx version and Asterisk version.

I made sure to use the same usernames/passwords in the new system that I was using in the old system. I’m not sure how a restore will behave if the same user/password combinations aren’t the same between systems.

How should I have done this? Will I get a Full backup of all the settings I need by selecting “Full Backup”? I’m assuming that by selecting Full Backup I am getting the other selections/templates (CDR’s, Config Backup, System Audio and Voice Mail) in one selection.

Are there other things that I should do in order to make this work?

I will ask the question regarding the Aastra xml scripts in another post.

Thanks for your help!