FreePBX Distro and Asterisk 14

Hello everyone.

We have the FreePBX distro 10-13.65.17. We tried to change the asterisk version from 13 to 14 (beta) with asterisk-version-switch utility. But when it upgraded, FreePBX doesn’t connect to the Asterisk (red button appears in the right top)

Asterisk service is not available, it periodically tries to start, but stops immediately. What this behavior may be related?

Try reboot the server or kill asterisk process!

I already had tried to reboot the server, but it didn’t help.

Check logs!

Is asterisk running as root

No, as asterisk

19642 asterisk 20 0 1915m 59m 14m R 50.2 3.2 0:01.51 asterisk

The issue became more clear. When I upgraded asterisk to version 14, logs had warning information that codec 729 should be reinstalled. When I had removed from /usr/lib64/asterisk/modules, Asterisk didn’t stop more. But I don’t know how do I need to reinstall it?
Although, I was interested Asterisk 14 in its codec OPUS, but I have seen it doesn’t work in this version too?

1 Like

What can you say about OPUS in the FreePBX distro?