Freepbx configuration - different Signalling and RTP ips


Because of various circumstances, I “inherited” an Asterix/Freepbx server into my network. Pretty simple setup, one trunk with 8 outgoing concurrent calls.

Now, my ISP is upgrading some equipment on their end so it provided me with new ip addresses, to change them in our equipment.

  • signalling 99.xx.yy.10, port 5060/udp
  • RTP/media: 99.xx.yy.41

And here is my problem, since my extensive experience in old-style analogue PBX’s does little to help me.

I assume that the signalling ip is the one found in Connectivity -> Trunks -> pjsip Settings -> General tab, SIP Server field.

But the RTP/Media ip address? Where do I change that? I am reading through the documentation now, but anything to point me in the right direction would be most useful as I’m running out of time.


I’m not sure how you’d do that. If it was mine, I’d set up the system using .10 as the SIP port address (you’ve got that already) and then set up an inbound route through the firewall for the .41 address. Forward all of the UDP traffic on ports 10000-20000 to the server. In the Integrated Firewall, set up both external addresses as “trusted”. Theory says that the SIP traffic will connect internally, so inbound calls should work.

The only place I’m sure about is the outbound RTP traffic. I’m not sure how to make sure it gets to the .41 server…

Ah. So am I to understand that the RTP/Media ip address is not a setting I have to make in the Freepbx admin interface, but actually a route I have to allow through the firewall?

Both ip’s I already added to the trusted zone in the integrated firewall.

Mention: I have NO incoming calls. All this Asterix install ever does is provide ONLY outgoing calls.

Edit: I have found the file pjsip.transport.conf in /etc/asterix/… and the lines signalling and media ip do show up. However, even if I set them up there and create trunks + outbound routes + queues, it still doesn’t work. Me lost.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.