Freepbx config issue after upgrading AsteriskNow

Hello everyone,

We run AsteriskNOW 1.7.1, and this afternoon we did a “yum update” to upgrade the system. Afterwards, we went to freepbx and did a module update first as the upgrade messages told us. We then tried to reload the configuration but that does not work.

We now run:

The module admin page tells us:
FreePBX Framework FreePBX Disabled; Pending upgrade to
Seems like an odd message? Or does it just say our upgrade is still in progress and not finished as we haven’t reloaded the cfg yet?

Now onto the main problem: when we apply configuration, this process ends in the following message:
PHP Fatal error: Call to undefined method extensions::addSectionComment() in /var/www/html/admin/modules/core/ on line 1725

This crashes the reload.

I had the same problem. I resolved by restoring a backup made via the FreePBX backup-module. It worked fine.

The best way I found that worked for me is by excluding the freepbx package:
yum --exclude=freepbx update

I still check most modules manually and make sure the upgrade is not going to “retrograde” anything.

Thanks to the VM world, I now save a snapshot before any update. to be on the safe side and delete it a few days/weeks later.

I’ve got the same issue… any updates before I start diggin?

That is the danger of running yum, it downgraded your FreePBX to 2.7. You need to reinstall FreePBX 2.8