FreePBX change alert-info header for SIP phones, calls. / paging


Dear FreePBX users and experts,

I been using FreePBX for quite a while and I have to admit I’m a very happy user of FreePBX.

However I still have some troubles till this day,

I got myself some Nortel 1140e SIP phones a while ago. And I’ve got these working with my FreePBX installation.
However the paging option from FreePBX to the Nortel 1140e phones, won’t answer on handsfree when I make an internal paging call to the phones. They just keep ringing…

So I took my time to read around about this and I found out together with some help that the issue that I’m facing is the different patterns and standard of the SIP paging header / alert-info are the cause of my phone ringing instead of answering.

So I read on the internet that someone with Polygom phones, that had the same problem with these not answering paging calls.
This guy describes how to change the alert-info for asterisk, however I could not figure out how to do it for FreePBX.

So I searched yet again and found this website:

With more information about distinctive calls and alert-info for calls.
However I’m unsure if:

  1. This information is up to date.
  2. This information is correct.
  3. I find the tutorial hard to understand exactly what I’m supposed to do.

So I’m wondering if someone has some suggestions on what I should do and which file and where I should edit instead of following a tutorial half-way knowing what I’m actually doing.

Thanks already for your time and answers,
Much appriciated,

(TheJames) #2

If you know the useragent and the required headers I would put them in a feature request at


I don’t know the correct headers and I want to test them by changing adding custom ones? And then maybe I can ask them it to add these in a feature request

However where do I edit the file etc.?

(Tony Lewis - #4

You need to know the correct header and alert info. Once you know that you can add it to the paging_autoanswer database table in MySQL


Can I perhaps test certain known headers? because the header information is not public on the internet, nor in the manual.

(Tony Lewis - #6

Sure I already told you the database table to add them to


Thans for he helps so far, I’ve not edited anything yet but I wanted to show you my asterisk debug, when I send a paging request to my Nortel phone (Avaya) it rings 1 time and then ends the call, the phone reports “busy”.
And the call is not answered and dropped by the Nortel phone.

Maybe can you analyse this? I can’t figure out what’s going wrong. Maybe it’s clear but I can’t see.


You need to add some level of verbosity to your logging to seperate the debug info from the dialplan.

core set verbose 6 should be good.


Hi! Sorry
I did not have much time so it took me a while, here is a debug with core verbosity on 6. :wink:


can anyone please reply to this? I really need this to work :./


With no verbose dialplan logging probably no help will be forthcoming.


I thought I set the verbosity to 6 in the last pastebin. Do you know what commands I need to execute on the CLI to make the dialplan be verbosity 6 like you asked?

Please let me know!


I do and so should you if you are trying to do something as complicated as you are.

core set verbose (your choice)

Come on dude read an FM or two :slight_smile:


I did exactly that!!! I did core set verbose 6 and then I made this pastebin :confused: Line 129 + Line 145! On the latest pastebin I made and posted earlier this week


If you post from a logfile and you should, that is also covered in the manuals best read and absorb all of

it’s under logger.conf and you will need verbose as an argument to the logfile.


Okay, but isn’t that information already in the log i send you? I made the intercom call during that log so you could see it. :frowning:
I am reading that, but isn’t the required info already there?


Possibly it is but no-one has the patience to see the wood for the trees (at least I don’t) , let’s start over, turn off your debug, it’s not useful, turn on your verbosity and add sip debugging for the extension you are concerned with, neither the debug nor the dialplan will be diagnostic, but will set a time framework for the SIP transactions being sent to the phone.


Hi dicko,
I have done as you requested, please refer here to see the debug.

My extension I am ringing (nortel phone) is 11. So that is why PEER 11.

is this okay with you?


Eventually you supplied what you where asked two weeks ago, your user-agent is

User-Agent: Avaya IP Phone 1140E (SIP1140e.

so as you where advised you would need to:-

mysql -u yourmysqluser -pyourmysqlpassword -D asterisk -e " insert into paging_autoanswer (useragent,var,setting) VALUES (‘Avaya’,‘ALERTINFO’,‘Alert-Info: Info=yourstring’)"

You will need to replace ‘Info=yourstring’ with the settings that your particular phone needs to autoanswer, I’m sorry I have no knowledge of those phones but “Auto Answer” and “autoanswer” are common.


Hey dicko! Thanks for telling me it so quick! :slight_smile: wow! so your suggesting to try “autoanswer” ? :slight_smile: or Auto Answer in the “yourstring” variable? :slight_smile: