Freepbx can no longer backup to remote drive since last update

We are using a recently installed and activated freepbx (from sangoma ISO). Backups were working consitenly until last week. Last week we ran both an update to all modules and a yum update.
Since then backups do not work. They start storing in the remote drive and fail with some broken pipe error.
The same error happens if we attempt an SCP copy directly from the terminal. We have tested from the freepbx server to 2 different remote servers and both have failes, so we know the problem is on the local side.
We tried changing the alive time on the ssh config but it made no difference.
Somebody here noticed something about “locale” not being set when the scp command is run.
We tried forcing locale to UTF8 on a few related config files and that worked, we were able to complete the file transfer but after a system reboot we were back to the same broken pipe problem.
We have also attempted to uninstall the openssh-clients and reinstall, but that made no difference either.

Any ideas? anything we should try?

thanks!

Can you post the full error?

Hi PitzKey,
this is what currently shows up on the backup error

Initializing Backup 2
Backup Lock acquired!
Running pre-backup hooks...
Adding items...
Building manifest...
Creating backup...
Storing backup...
packet_write_wait: Connection to 10.10.8.200 port 22: Broken pipe
lost connection
SCP Error (1) - Received [] from /usr/bin/scp -o StrictHostKeyChecking=no -i /home/asterisk/.ssh/id_rsa -P 22 /var/spool/asterisk/tmp/20180604-174220-1528152140-14.0.3.6-1163292700.tgz [email protected]:/Volumes/Promise/Backups/asterisk_backups/srv2//srv2_daily
Running post-backup hooks...
Backup completed with errors!

and this is the error that comes up if I run SCP from the terminal

20180601-123839-1527874719-14.0.3.6-1463346921.tgz 0% 0 0.0KB/s --:-- ETApacket_write_wait: Connection to 10.100.8.200 port 22: Broken pipe
lost connection

I can no longer reproduce the locale not set error which was in addition to these errors since some config files were changed (not by me). The transfers do not complete, they stop after a few kb and these errors still show up

hopefully this gives you some useful info to help me debug this.
thanks.

we set everything back to how it was when things started failing. The Locale error shows up during login to the terminal.

Last login: Tue Jun  5 12:29:18 2018 from 10.10.9.1
-bash: warning: setlocale: LC_CTYPE: cannot change locale (UTF-8): No such file or directory
locale: Cannot set LC_CTYPE to default locale: No such file or directory
______                   ______ ______ __   __
|  ___|                  | ___ \| ___ \\ \ / /
| |_    _ __   ___   ___ | |_/ /| |_/ / \ V /
|  _|  | '__| / _ \ / _ \|  __/ | ___ \ /   \
| |    | |   |  __/|  __/| |    | |_/ // /^\ \
\_|    |_|    \___| \___|\_|    \____/ \/   \/

NOTICE! You have 4 notifications! Please log into the UI to see them!
Current Network Configuration
+-----------+-------------------+--------------+
| Interface | MAC Address       | IP Addresses |
+-----------+-------------------+--------------+
| eth0      | 82:B0:BB:1C:6E:96 | 10.10.7.97  |
| eth1      | A2:B6:4B:20:E2:80 |              |
+-----------+-------------------+--------------+

Please note most tasks should be handled through the GUI.
You can access the GUI by typing one of the above IPs in to your web browser.
For support please visit: 
    http://www.freepbx.org/support-and-professional-services

+------------------------------------------------------------+
| Your system is currently up to date!                       |
| Your PBX is up to date.                                    |
+------------------------------------------------------------+
[[email protected] ~]# 

Hopefully this info helps.
Any suggestions as far as what we should try?
thank you

Just try to SSH into that?

ssh [email protected]

If that works, then try to manually SCP something. You have a lot of switches on that built in command.

Hi, I did that. SCP doesnt work. Look at my previous messages to see the broken pipe error.
Anything else you can think of that we should try?
thanks!

I would try to connect to the remote machine with extra verbosity

ssh -vv [email protected]

scp uses the same authentication mechanism and the reason for failure should be apparent.

You did not specify how you ran SCP manually. I was saying to just run a single file transfer without the switches and such. Also I would suggest just a small file like a conf file.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.