FreePBX calls hanging up after 30 seconds

Here we go again with the "My calls from my PBX are hanging up after 30 seconds."
First let see my environnement.
I have a RasPBX (FreePBX) running for over 6 months. everything is fine.
Most of my users are outside my Home.
My router ports are set as follow
29-Dec-21 11-54-48 AM
Ny NAT is has follow
29-Dec-21 12-01-44 PM

I am builting another FreePBX which is run as a VM on an HP DL-360.
This one is internal only with no inbound access from internet.
So i have no port routed in my router.
NAT is has follow
29-Dec-21 12-05-44 PM
I have 2 extensions 71001 and 71002 pgsip.
I can call between them and talk but after 30sec both hangup.

Could it be because i am running 2 PBX on the same LAN 192168.1.x? Or anything else.

My Next step is to shut down the Raspberry PBX and see if it solved the problem.
I have to notify user before i can do so.
Anyhelp or hint is welcome.
Daniel VA2DG

Thank for the link but i have already done so.and been looking for 2 days.
If i am asking it is because none of the reply so far works for me.

Everyone that asked that question were not in my environnement.
They all had their PBX going thru internet and had trunks.
My setup is a STAND ALONE PBX on my internal Network.
All phone have this PBX IP as proxy. So there is no port to open.
I have talk path both ways but after 30s it just drop.

So i repeate my question? Could it be because i am running 2 PBX on the same LAN 192.168.1.x? Or anything else. (FreePBX on Raspberry anf FreePBX on HP DL360 as a VM )

Unlikely that is the issue, if you have signaling (ringing) and a two way voice path (RTP Ports) the issue is likely a NAT issue.

You could turn on SIP logging and do a log capture

You could also perform a Wireshark to track the call. That will help illuminate what is happening.

Check your UDP timeout value in the firewall. Set to 300 if you can.

UPD Timeout value in the firewall ? FreePBX Firewall or my router Firewall?


Also, verify that your SIP settings have the correct External IP and that your Local Network settings are right.

Well Still problems.
i have power off the RaspBerry PBX.
moved the port forwarding to the new Server IP in my router.
I have created my 7 extensions i had in the RasPBX 2xx into the new PBX . They are scattered all over the province and they registered back to new PBX with no problem.
But this time no audio at all. So i did change the Direct Media to NO in ext 201 and 71002.
If Direct Media is not set to No then i have no audio.

Now calling 71002 from 201 i get my talk path both way but still disconnect after 30 sec.

I also move the PBX itself in the DMZ and same issue.
Still troubleshooting.

The RasPBX was very easy to setup. just created extensions and setup port forwarding and that was it.
But the FreePBX on a real server seem to be a pain.

This may be a silly question, but on the internal-only PBX, does your External address match the IP address of the box?

when you set the DMZ in the router your tell the router to route the request to the PBX IP.
any other request on other port will be route to the port forwarding.
Anyway until i solve the problem internally i mean phone to phone on the same internal network there is not sense putting it on the DMZ for external people yet.
will just move it back internally and may be isolate it into another subnet outside of my regular home network. Then once it is fixed i can put is back on my home lan.

I’m out of suggestions. I would try putting a value in there for a test to see what happens though. But that’s just me.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.