FreePBX Blacklist - Goes straight to silence

I’ve got Asterisk 1.4 and FreePBX 2.5.1 installed. All works fine in Freepbx except blacklist. I added my cell number to test it out. When I called from my cell instead of getting the asterisk operator It just is complete silence, and the call never disconnects. Has anyone had this issue before. If so, was there a fix for this issue?

Check to see if you turned on fax detection on the incoming route but do not have the supporting fax stuff installed (like nvfaxdetect). I had this happening on my box while setting up inbound faxing, but it only happened with calls w/o caller ID information for some reason.

I tried disabling the fax detection in the “inbound route”, restarted asterisk , and rebooted, but blacklisted numbers still go to a “silent” hold effect, and the call doesn’t disconnect until the caller hangs up.

Here is the output from asterisk as I made the test call for the number I blaclisted:

[email protected]:~# asterisk -vvvvvvvvr
Asterisk 1.4.25.1, Copyright © 1999 - 2008 Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

== Parsing ‘/etc/asterisk/asterisk.conf’: Found
== Parsing ‘/etc/asterisk/extconfig.conf’: Found
Connected to Asterisk 1.4.25.1 currently running on Mythbox (pid = 14896)
Verbosity was 3 and is now 8
– Remote UNIX connection
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
– Executing [17772********@from-pstn:1] Set(“SIP/callcentric_in-016cc500”, “__FROM_DID=17772******”) in new stack
– Executing [17772********@from-pstn:2] Gosub(“SIP/callcentric_in-016cc500”, "cidlookup|cidlookup_2|1 ") in new stack
– Executing [[email protected]:1] Set(“SIP/callcentric_in-016cc500”, “CALLERID(name)=”) in new stack
– Executing [[email protected]:2] Return(“SIP/callcentric_in-016cc500”, “”) in new stack
– Executing [17772********@from-pstn:3] Gosub(“SIP/callcentric_in-016cc500”, "app-blacklist-check|s|1 ") in new stack
– Executing [[email protected]:1] LookupBlacklist(“SIP/callcentric_in-016cc500”, “”) in new sta ck
– Executing [[email protected]:2] GotoIf(“SIP/callcentric_in-016cc500”, “1?blacklisted”) in new stack
– Goto (app-blacklist-check,s,4)
– Executing [[email protected]:4] Answer(“SIP/callcentric_in-016cc500”, “”) in new stack
– Executing [[email protected]:5] Wait(“SIP/callcentric_in-016cc500”, “1”) in new stack
– Executing [[email protected]:6] Zapateller(“SIP/callcentric_in-016cc500”, “”) in new stack
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Parsing ‘/etc/asterisk/manager_additional.conf’: Found
== Parsing ‘/etc/asterisk/manager_custom.conf’: Found
== Manager ‘admin’ logged on from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
== Spawn extension (app-blacklist-check, s, 6) exited non-zero on ‘SIP/callcentric_in-016cc500’

Just to make sure it is related to the blacklist module, I would disable the module, then test to make sure things work, that is how I finally figured out my problem was with my only having partially setting up faxing.

If you still have a problem, then the problem is obviously not with the blacklist module…

Here’s the story, I’ve got freepbx & asterisk on another box, and blacklist works. The PC I want to run asterisk, freepbx, and mythtv as the dedicated server is the problem box that blacklisted goes to silence.

I used the pc that blacklist works on and have marked the sections of where the non-working pc stops in its tracks when trying blacklist:

=========================================================================
== Parsing ‘/etc/asterisk/asterisk.conf’: Found
== Parsing ‘/etc/asterisk/extconfig.conf’: Found
Connected to Asterisk 1.4.22 currently running on KG (pid = 6797)
Verbosity was 3 and is now 17
– Remote UNIX connection
– Executing [1777*******@from-pstn:1] Set(“SIP/1777*******-09d84028”, “__FROM_DID=1777*******”) in new stack
– Executing [1777*******@from-pstn:2] Gosub(“SIP/1777*******-09d84028”, “app-blacklist-check|s|1”) in new stack
– Executing [[email protected]:1] LookupBlacklist(“SIP/1777*******-09d84028”, “”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/1777*******-09d84028”, “1?blacklisted”) in new stack
– Goto (app-blacklist-check,s,4)
– Executing [[email protected]:4] Answer(“SIP/1777*******-09d84028”, “”) in new stack
– Executing [[email protected]:5] Wait(“SIP/1777*******-09d84028”, “1”) in new stack
– Executing [[email protected]:6] Zapateller(“SIP/1777*******-09d84028”, “”) in new stack <=================== Stops here

Doesn’t do any of the below

-- Executing [[email protected]:7] Playback("SIP/1777*******-09d84028", "ss-noservice") in new stack
-- <SIP/1777*******-09d84028> Playing 'ss-noservice' (language 'en')
-- Executing [[email protected]:8] Hangup("SIP/1777*******-09d84028", "") in new stack

== Spawn extension (app-blacklist-check, s, 8) exited non-zero on 'SIP/1777*******-09d84028’
KG*CLI>

This is basically the same behaviour I was having that turned out not to be the blacklisting at all. So disable the module and see if the problem is still there. In addition, look at the /var/log/asterisk/full log to see if anything else is being reported.