FreePBX Beta 14/14 after startup a "fwconsole restart" nessesary

Hi Folks,

im runing FreePBX 14/14 Beta.

When ever I start up the server, I have to login via console (putty usually) and run the

“fwconsole restart”

command. It then tells me that everything was not runing, starts it up just fine, and voila the system is fine from then on, working like a charme.

What do I need to check why it dont start those dbs and services at startup?

Is there somewhere a “server online after startup” switch I may have changed unintentionally?

I run all module & system updates etc.

I once did run out of disc space during an update (due to miss configured backup) but I did go back to a clone Id made before the update and corrected backup config and resized the disc before restoring the clone.

Any hints?
Thanks
Cheers Manne

Is this a distro install?

Yes, its right from the freepbx download section, I did choose 14/14 for install. w/o LVM.

I downloaded it somewhere end of January beginning February. details follow.

Also, it was not like this in the beginning.

It showed up periodically, then later became a permanent problem.

sng7-fbpx-64bit-1612.iso

Turning off LVM can cause strange issues like what you are running into. It’s generally best to leave it enabled.

I would start from bash with:-

cat /proc/partitions

and

mount

if it leaks that you are using LVM2 (whether you wanted to do that or not) , then we can work out your LVM2 problems

Thanks for trying to help me :slight_smile:

Heres the output:

[[email protected] /]# cat /proc/partitions
major minor  #blocks  name

  11        0    1048575 sr0
   8        0   62914560 sda
   8        1     819200 sda1
   8        2     819200 sda2
   8        3   61275136 sda3
[[email protected] /]# mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,size=1190532k,nr_inodes=297633,mode=755)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct,cpu)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_prio,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/sda3 on / type xfs (rw,relatime,attr2,inode64,noquota)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=26,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/sda1 on /boot type xfs (rw,relatime,attr2,inode64,noquota)
tmpfs on /run/user/0 type tmpfs (rw,nosuid,nodev,relatime,size=240012k,mode=700)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
[[email protected] /]# df
Filesystem     1K-blocks    Used Available Use% Mounted on
/dev/sda3       61264896 9837896  51427000  17% /
devtmpfs         1190532       0   1190532   0% /dev
tmpfs            1200044       0   1200044   0% /dev/shm
tmpfs            1200044   33100   1166944   3% /run
tmpfs            1200044       0   1200044   0% /sys/fs/cgroup
/dev/sda1         815788  176664    639124  22% /boot
tmpfs             240012       0    240012   0% /run/user/0
[[email protected] /]#

for good measures I added df

I avoided LVM because I run this one in a VirtualBox VM and have no need vor LVM, it just adds a layer of complexity in case I have to or want to resize the HDD.

Thanks again.
Cheers
Manne

PS: and honestly, I never made it to fully understand the exact ways of LVM, since I never had to tackle it with any other of my systems, so I kind of avoid LVM like the plague…