FreePBX behind Sonicwall

I have customer with a FreePbx server that has been running flawlessly behind a PfSense firewall. They have now decided to switch to a Sonicwall. With the Sonicwall in place I can no longer get the FreePbx to pull an external IP in the NAT settings when I hit the Detect Network settings option I just get the message “Could not resolve Error” (This is the first time I have had this issue, and I have installed FreePbx behind Untangle, PfSense, Netgear etc.) I have even tried to input the customers static Wan IP manually with no luck. So obviously my FreePbx can not connect up to my SIP trunk from the ITSP through the Sonicwall. Unfortunately I only maintain the FreePbx the IT consultant that was hired to install the Sonicwall has assured me that the Sonicwall is configured properly, and it is my FreePbx Server that is not configured correctly. I can not figure out what settings I would need to change in the FreePbx differently for the Sonicwall that I have not had to change for any other Firewall I have used in the past.

1 Like

Can you ping from the PBX?

I don’t remember any issues with the stable maintenance release firmware versions of sonicwall in the last year or so.

Good to know the newer supported models work.

Try getting an older and unsupported model to work is practically impossible.

Rather than buy a new Sonicwall for a client, I went with a new Ubiquiti Edgerouter instead. However, now that Sonicwall has a handle on this, they are fine too I suppose. I just had a grudge, so got the Ubiquiti.

If the vendor doesn’t support it, we don’t support it either.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.