FreePBX ARI loads blank page

EDIT I have a fresh install of AsteriskNOW 1.7.1 i386 using Asterisk 1.6.2.19 with FreePBX 2.9.0.7.

I cannot get the ARI page to load anything other than a blank page. After turning on display error messages in php.ini, I get:

Fatal error: Call to undefined function parse_asterisk_conf() in /var/www/html/admin/common/php-asmanager.php on line 33

FreePBX ARI Framework is at 2.9.0.6 under modules.

Can anyone please help me out with this!

It would be greatly appreciated.

Thank you!!

bump

It looks like you have an incomplete install.
What do you mean by “I have a clean install of [email protected] using Asterisk 1.6.2.19 with FreePBX 2.9.0.7.”?

[email protected] is a VERY old distro. I suggest that you install FreePBX Distro instead.

I am using AsteriskNOW 1.7.1.

I apologize for the misunderstanding. Not really sure why i wrote [email protected]

problem still exists

Thanks

Try clearing your browsers cache or try a different browser to see if the problem is resolved.

BF

Fresh install of PIAF Purple running FreePBX 2.9.0.7
Three installs on test systems and both same issue Blank ARI page ofter complete upgraded to 2.9. Prior to upgrading to 2.9 ARI Recordings Tab worked great. Any other suggestions?

A few things I have tried: the passwd-ari command, breaking the ari module and uninstalling, reboot, and reinstalling it (Ver. 2.9.0.6), backing up system prior to upgraded to 2.9 and then upgrading to 2.9 then reverting back to 2.8 will leave ARI page broken.

Spent some time on this, so any help on this would be greatly appreciated.

Thanks,

Hey

Thanks for the info! Glad you were able to get it functioning again.

Unfortunately, I don’t have the googlevoice module installed.

When I look at the /tmp/freepbx_debug.log and open up the recordings page, the only thing that it says is:

  2011-Jul-21 09:52:39    /var/www/html/admin/libraries/gui_auth.php:4
  [NOTICE]: A session had already been started - ignoring session_start()

And the recordings page (since I turned on display errors in php.ini) says the following still:

 Fatal error: Call to undefined function parse_asterisk_conf() in    /var/www/html/admin/common/php-asmanager.php on line 33

The browser’s cache is not the problem. I cleared cache, as well as tried from various computers/types of browsers. Same error message and problem arise each time.

I have php-asmanager.php in my /var/www/html/admin/common directory

[[email protected] common]# pwd
/var/www/html/admin/common
[[email protected] common]# ls -lh php-asmanager.php
-rw-rw-r-- 1 asterisk asterisk 20K Jul 7 07:45 php-asmanager.php

I have FreePBX ARI Framework 2.9.0.6 installed.

The following link is to an image hosting site showing a screenshot of my Basic Module page:
Basic Modules Admin Page

Hopefully this will help others with similar issues. I had been working on this for days trying to determine why my fresh install of PIAF Purple had recordings page break after upgrading to 2.9. Reading posts and scouring forums with about 4 different test installs trying different methods.

I finally dug into the debug log at /tmp/freepbx_debug.log and noticed the following added each time I opened the recordings tab.

“/var/www/html/admin/modules/googlevoice/functions.inc.php:29
[WARNING]: require_once(libraries/extensions.class.php) [function.require-once]: failed to open stream: No such file or directory”

I had planned to test the Google Voice out after I got the system up and running so I left the module installed as it was installed by default…

So I uninstalled the Google Voice module!!!(

As soon as I did this and applied changes Recordings pages work again. I don’t know if this is a bug in the Google Voice module, PIAF or Free PBX. But there has been little documentation on having blank recordings pages.

Let me know as I had found others with the same issue with no replies.

FreePBX 2.9 does not have the php-asmanager.php in /var/www/html/admin/common/
You have an incomplete installation.

Go to Module Admin and check that you have FreePBX ARI Framework 2.9.0.6 installed and up to date.

I do not have php-asmanager.php in my system 2.9. As Mickecarlsson stated I believe that was in earlier versions. I did see that file mentioned in my searching for blank recording solutions (but it was referencing 2.6 I believe) But I looked to see if I had it anyways.

If I change the name of php-asmanager.php to php-asmanager_BACKUP.php I get the following error message when attempting to open my ARI Recordings page:

Warning: include_once(…/admin/common/php-asmanager.php) [function.include-once]: failed to open stream: No such file or directory in /var/www/html/recordings/includes/common.php on line 469

Warning: include_once() [function.include]: Failed opening ‘…/admin/common/php-asmanager.php’ for inclusion (include_path=’.:/usr/share/pear:/usr/share/php’) in /var/www/html/recordings/includes/common.php on line 469

Fatal error: Class ‘AGI_AsteriskManager’ not found in /var/www/html/recordings/includes/common.php on line 197

Was this a fresh install of AsteriskNOW? Renaming or deleting the php-asmanager.php will not help as there is something that is calling for it. Something has gone wrong somewhere. You may want to try to reinstall, as sometimes it is faster then trying to determine which file has gone south. Another thing you could try is to uninstall the ARI Module and reinstall it. I don’t know if it is the approved method but… rename the file /var/www/html/admin/modules/fw_ari/module.xml and then go into the GUI and go to modules ARI will now be broken go to actions and uninstall it, reboot and check for updates, and install the ARI Framework. Be sure you have a backup in case things go wrong.

Double post

[SOLVED]

Yes this was a fresh install as of ~2 weeks ago.

I just uninstalled the ARI Module --> Rebooted --> Reinstalled ARI Module.

Now it works!!

hah I guess it was just something that broke in that module.

Thank you for all your help and suggestions.

Much appreciated

Thanks

  • Chris

[SOLVED]

Glad you got it working. I know how frustrating it can be.

I too have the same issue but the above fix did absolutly nothing for me. I upgraded to 2.9 through the module admin according to the above steps. I have also remove ARI module and rebooted then reinstalled with no luck. Any ideas as to why this is broken?

This worked perfect for me. Thanks for a huge time saver!

when google voice module is removed, the recording panel is back.
reinstalled google voice module, the recording panel goes blank again.