FreePBX and Yealink Phones - Voicemail Feature Codes not Working

FreePBX 2.210.62-5
Yealink T26 and T32 phones

The phones register and appear to work just fine in all aspects except voice mail access. Whenever dialing *97 or *98 on the phones, the phone immediately hangs up without ever reaching a prompt for voice mail mailbox or password.

I’m relatively new to FreePBX but I assume this may be some sort of feature code conflict of the Yealink and FreePBX (<-total guess). The *97 and *98 work perfectly fine on our Polycom 501’s, 601’s, and soft-phones such as X-Lite so at least I know the FreePBX box is setup correctly :slight_smile:

Any help is greatly appreciated! I’m very curious to find out what stops these feature codes from working on the Yealinks and not other phones.

Commonly the “vertical services” on the phone might preempt *9[78]

After some tinkering around with feature codes, dial plans, and all manner of adjustments on the server, finally remembered to check the log (Doh!) and found that it was unable to translate the language of G.729 when dialing feature codes. Further research showed that this is due to not having licenses purchased for the usage of G.729 on your server (Average of $10/channel).

Without the logs, I would never have found this out! What’s odd is that incoming and outgoing calls worked just fine but the second you tried using a feature code, the server would stop you.

Switched the Yealink phones to use G.722 and PCMU (G.711) and they are working like a charm now.

It’s not odd, it is to be expected. If you don’t have g729 licenses, then your PBX cannot process that call in line, but asterisk will “pass through” any g729 calls and let the endpoints negotiate the legitimacy of that call, you will need one license for each concurrent leg of all calls that you process through Asterisk.

Ah I see, thanks for the link! I was looking for more information on how the licensing worked to help explain the way it handled the calls and licensing.