FreePBX 2.9 to 15

Hello FreePBX community,

now that the conversion tool is gone, is there another way to migrate from 2.9 to 16 without having to do everything manualy?

thank you.

There is no FreePBX 16 yet. FreePBX 15 allows Backups to be restored from legacy versions:

Oh, sorry. It is asterisk 16.
Thank you for your reply.

I have personally done FreePBX 2.11 to 15. Not done one with 2.9

The magic of virtualization makes it simple to test.

Hello again,
i took a backup of the old machine and it gave me a directory with 13 .tar files. Because i could not select all 13 files i compressed them into one file (i tried .zip, .tar, .gz). When i tried to restore to the new machine i got these errors:

splitbrain\PHPArchive\ArchiveCorruptedException thrown with message “Header does not match it’s checksum”


#5 splitbrain\PHPArchive\ArchiveCorruptedException in /var/www/html/admin/libraries/Composer/vendor/splitbrain/php-archive/src/Tar.php:586

#4 splitbrain\PHPArchive\Tar:parseHeader in /var/www/html/admin/libraries/Composer/vendor/splitbrain/php-archive/src/Tar.php:151

#3 splitbrain\PHPArchive\Tar:extract in /var/www/html/admin/modules/backup/Models/BackupSplFileInfo.php:51

#2 FreePBX\modules\Backup\Models\BackupSplFileInfo:getMetadata in /var/www/html/admin/modules/backup/Backup.class.php:713

#1 FreePBX\modules\Backup:myShowPage in /var/www/html/admin/modules/backup/page.backup.php:3

#0 include in /var/www/html/admin/config.php:646

Do i need to open another thread?

Thank you.

How did you make a.backup? The FreePBX backup module should only generate a single archive file.

My mistake, it was older backups together. So i got the correct backup file now but when i upload it, it gives me this message:
Running with: /usr/sbin/fwconsole backup --restore=’/var/spool/asterisk/backup/uploads/20201011.11.54.33.tar.gz’ --transaction=‘6d4fc2c8-0cde-4368-9fbb-f0386d6dfd3e’
Determining backup file type…type is legacy
_Legacy CDR Restore Option: 0 _
Starting restore job with file: /var/spool/asterisk/backup/uploads/20201011.11.54.33.tar.gz
Extracting backup…
Parsing out SQL tables. This may take a moment depending on backup size.
Found 0 database files in the backup.
Restore completed successfully

but after reload, nothing changes.

thank you.

There is no MySQL database in the backup file. You don’t have a complete backup.

From the backup option i clicked all options (Admin Web Directory, CDR, Operator Panel, Overwrite Backup Settings, System Recordings, Voicemail, System Configuration). What additional files should i add?

thank you.

On my phone and the wiki sucks to dig through this way

I think this is the Pre 15 backup instructions

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.