FreePBX 2.9 cmpatibility

Does anybody know if FreePBX 2.9 is compatible with asterisk 11? I just installed AsteriskNOW with Asterisk 11 and FPBX 2.10, I updated the framework to 2.11 and then I added my 600+ extensions with a bulk extension import. I now relado and there is this ridiculous process: retrieve_conf, that uses 100% of the CPU for HOURS and next time I log into the web interface the ‘Apply COnfig’ button will still be asking to be ‘pressed’. In asterisk 2.8 I used to have 800+ extensions and a reload would only take seconds.

Once again I make my point valid… Sorry developers…, but I really, really dislike your new web interface…

Thank you all!

The web interface is not what is slowing it down. and no 2.9 will not work with asterisk 11.

There is something else going on with your system.

“new” web interface? It’s been like this for 2 years now.

Yeah, I know it’s been out for years. Now you know how long it has been since I’ve been avoiding it…! I have 8 servers, all running on FPBX 2.9 or older.

What do you suggest I should check to fix this underlaying process that gets called on every reload?


Ok. So you hate the GUI. It’s not changing. No matter how much you complain. So let’s move past all of the reservations you have about it.

what happens when you run (on the cli): amportal a r

Yeah…, I thought it wouldn’t after waiting for over two years for it to do so… :frowning: Too bad for me…

Anyway. Amportal a r hangs when calling the same retrieve_conf. If I send a sigterm I get this:
sh: line 1: 3413 Killed /var/lib/asterisk/bin/retrieve_conf 2>&1
Error(s) have occured, the following is the retrieve_conf output:
exit: 137
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asterisk
Added to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = amp111
Added to globals: AMPDBENGINE = mysql
Added to globals: AMPDBHOST = localhost
Added to globals: AMPDBNAME = asterisk
Added to globals: AMPDBUSER = freepbx
Added to globals: AMPDBPASS = fpbx
Added to globals: VMX_CONTEXT = from-internal
Added to globals: VMX_PRI = 1
Added to globals: VMX_TIMEDEST_CONTEXT =
Added to globals: VMX_TIMEDEST_EXT = dovm
Added to globals: VMX_TIMEDEST_PRI = 1
Added to globals: VMX_LOOPDEST_CONTEXT =
Added to globals: VMX_LOOPDEST_EXT = dovm
Added to globals: VMX_LOOPDEST_PRI = 1
Added to globals: MIXMON_DIR =
Added to globals: MIXMON_POST =
Added to globals: DIAL_OPTIONS = Ttr
Added to globals: TRUNK_OPTIONS = Tt
Added to globals: TRUNK_RING_TIMER = 300
Added to globals: MIXMON_FORMAT = wav
Added to globals: REC_POLICY = caller
Added to globals: RINGTIMER_DEFAULT = 15
Added to globals: TRANSFER_CONTEXT = from-internal-xfer
Core set ALLOW_SIP_ANON because Sip Settings Module not enabled

Not sure if it is useful…

Thanks for the help!

Right. So this is my point. Your issue has nothing to do with the gui. Nothing at all. Do you first understand that?

Check your DNS.

I bet it isn’t working

Well…, I installed the SIP and IAX settings module (I remembered that in the past it would refer to those modules in the logs). I did an ‘apply config’ and it takes a while (BIG while, like 5 minutes), but it will eventually result succesful.

…I’m thrilled though…, DNS? Why would the script need DNS, what does it look for? Honestly I’m a little lazy to read the 900+ lines of code. Add the fact that I know very little on programing, which means I would need like a whole week to understand all the code throughly. But really…, DNS?

Well…, I was able te retireve files (modules) with wget. I was also able to update my distro with yum… What domain is the server looking for?

What script are you talking about?

FreePBX is not calling and DNS, Asterisk does, and I have no idea why it does, I have just seen this behavior once before. It was resolved fixing DS.

I mean the retrieve_conf sript located in /usr/lib/asterisk/bin.

I actually now created a new context: outbound_restriction, where the extensions have access to nothing. The retrieve_conf script now takes a few seconds to run. My extensions used to be in the from-internal context, now that I did the change the “Apply Config” runs faster (as retrieve_conf runs in a matter of seconds).

After talking to ALL of the development team we think that your issue is with asterisk reloading itself. Not with freepbx.

You can even prove that point by doing a ‘dialplan reload’ from Asterisk. How long does it take?