Freepbx 2.9 cannot play recorded calls from Call Monitor GUI

Dear Mr. Lindheimer:

I’m honored by your personal and fast response to my question. The more experience I have with the devs and senior forum members of Freepbx and PIAF, the more amazed I am. This is what the internet is supposed to be about!!

Answers to your troubleshooting tips:

  1. It was working prefect for version 2.8+. When I say it was working, I mean that once I logged into the web gui of Freepbx, and selected the “Recordings” tab, then logged in as admin, I would get the following:

Date Time Caller ID Source Destination Context Duration Monitor
030911 22:37:08 9998887777 <9998887777> 9998887777 [email protected] googlein 2 sec []
030911 22:37:03 701 <701> 701 1485554443333 from-internal 41 sec [***]

In the place where I entered “[***]” under the “Monitor” column on the second row, before there would be a little icon that looked like a speaker - if I clicked the icon, a Quick-Time Plug-in Version 7.6.9 mini-window would open and start playing the recorded call,

Now, the speaker icon is completely absent… which is no big deal, if someone could just point me to how to access the calls through webmin’s file manager or something else.

One thought on this issue: When I first got info using this excellent software back in mid-January or so, I had previously used the Google Chrome web browser. I had this very same problem on my first installation, while trying to access my Freepbx server’s web gui from Chrome.
It wasn’t a few days before I read Mr. Mundy’s install instructions LINEbyLINE before I caught the following from :
"Be aware that FreePBX has a difficult time displaying properly with IE6 and IE7 and regularly blows up with older versions of Safari. Be safe. Use Firefox."
For the entire month of February I used Firefox, and I was able to access the click-able icon on the Call Monitoring tab of Freepbx.
It worked like a dream…
And I really like the changes in Freepbx 2.9 - I really can’t claim my problem as a “beta-bug” because I may have easily made a mistake on my end when reinstalling PIAF for the 2.9 upgrade.

  1. Can I go back to the old calls that were recorded? No… I did a new fresh install of PIAF, ran their incrediblepbx18.x installer for google voice, then logged on the freepbx web gui and uploaded the 2.9beta module. I have manually backed up the recorded calls and I can access them from a usb drive, but I do this independently from the server. The backed up recorded calls are in wav format.
  2. One other issue I have, which may or may not indicate if it is a codec related issue, is when I now try to play the SYSTEM RECORDINGS from freepbx->Setup->System Recordings->(cosmic, nv-apps, nv-GenericWelcome, or nv-welcome) instead of hearing the audio file, the playback is just a distorted/corrupted/ robot static sound. In other words, it sounds like when a media player software is trying to play a file but does not have the proper codec to do so…This may or may not have been the same as in 2.8 - but I could swear that I was able to hear the different system recording files from within Freepbx web gui!
  3. When checking the Call recording format by going to Freepbx->Setup->General Settings (Call Recording), when I select the drop-down menu for the “call recording format,” something odd now happens in version 2.9.
    The available formats, in order of drop-down appearance, are:
    Quick Question A: Is there a difference between WAV & wav??? Is it case sensitive?
    Quick Question B: Google has a list of codecs that are compatible with its service here:
    Quick Google codec list:
    Again, I wonder if the codec classification is case specific - ie: gsm or GSM. My limited experience with Linux has shown me that case matters… :slight_smile:
    One other thought - Freepbx’s recording format drop-down menu’s last option is “g729” is this in anyway related to Google’s “G.722”? Do we drop the period in freepbx?
    Am I reading toooooo deep into all of this?

Final Question!!: Is it possible at all that my inability to access recorded calls (or even see if they are recorded) is related to the new MixMonitor/Monitor changes in 2.9? I’ve tried changing the advanced settings for Queues Module -> Use MixMonitor for Recordings to True and also False, but it doesnt seem to change anything that I can see.
Just for reference, I record ALL calls, inbound and outbound, without ANY interaction from the calling user or the called user - it’s all done on a system-wide basis. Additionally, I have not come close to exceeding the 32k or so recorded call files that Linux may or may not have issues with. Hopefully someday I will have those problems :slight_smile:
Hope my info provides some sort of help to the devs - I enjoy beta testing! I’m not yet sure if my type of feedback is what you are looking for, so if I can improve how I report please let me know!

sounds like it is most likely either a browser issue or a call recording format issue.

Check what format you set for the recording.

Since you say it was an upgrade, was it working before. Can you go back to calls that were recorded when it was a 2.8 system and play those?

Just trying to figure out if it was a codec change that was done by the upgrade inadvertently in case it is a bug.

I am having the same problem. Was running 2.8. Upgraded to 2.9 with the upgrade utility. Portal voicemail play stopped working.

I have updated to of the ARI Framework with ob_clean(); which was indicated in the above referenced thread to be the fix, but my play button in the portal still doesnt work. It opens the long box under the message row where the play status would be displayed but it remains empty and will not play. I have tried several browsers.

It worked perfectly before the upgrade and I have not changed any settings.

The ticket has been closed. What am I missing?

I have recorded new voicemails after the update and the same result. When I hit download, I get “404 File not found!”

Any help would be appreciated.


Ticket #5102

Now calls are intermittently not recording for whatever reason… There is no rhyme or reason, just some calls record and some dont… checked contexts, no issues there… extensions are set to always record… just for some reason calls arent recording… Some do, some dont…

My people still cant listen to their messages online. They have to do it over the phone. It seems like the online interface cant find the files. We have rebooted everything, tried several different browswers, nothing…