Freepbx 2.9 cannot play recorded calls from Call Monitor GUI

Recent upgrade to 2.9 beta - I did a new install using PIAF Purple iso. Set up system same as before when using 2.8. Problem I have now is that I cannot play the recorded calls when I access the Call Monitor.
I am able to login and SEE the call history, but now there is no audio logo for me to click in order to listen to the recorded calls.
I have set up the test extension to record all calls in and out.
Am I missing something here? I’m not saying it’s a bug in 2.9!!! It can easily be (or probably be) something I am forgetting to do.
Any advice would be very appreciated!

I am having the exact same issue, with the exact same results.

Can the developers confirm this is a bug?


I am having the exact same issue, with the exact same results.

Have the developers confirmed that this is a bug?


HI carsonrose, the only workaround that my operators are using is to click the ‘phone’ icon and have the system call them with the voice mail. Our more experienced users are using DISA on our IVR to dial in remotely to their mailbox. Either way not ideal, as they are working remotely, the call back is a local (or mobile) call.

Bump… Has anyone found a work around?

I even tried to convert the audio to a different format using sox, but it tells me the audio file is corrupt… I have tried both wav and WAV…

It is very easily reproduced using the FreePBX Distro. A new install render the issue with unplayable wav files.

Best regards
Henrik Larsson

Is there a way to fix these files or do I have to reinstall? We are required to record all calls…

Mikael, a developer, has provided a workaround in this thread:

There has been created a bug ticket for this issue:

For the message… but Im not having an issue with voice mail, just the recorded calls… and I cant seem to convert them with sox either, just tells me that the file is corrupt…

Will these files be able to be fixed or are they just a bunch of duds now?

Want to throw my name in the bucket. I am on 1.6 and am upgraded all the way. Same as above, can ssh them, cannot listen in browser.


Same thing here. Can’t listen records through GUI. If I download them through GUI then the sound is corrupted. Though if i get the files out from the filesystem with ssh then i can listen to them localy.
PS. system: pbxinaflash

Hi Philippe,

Sorry for the lack of information. I’ve managed to replicate the same issue on all our VMB’s.

They can see the speaker, phone and download icons. Using the speaker, the Q time bar loads, then greys out. Using the download it brings up media player, Nero etc and we get a message to advise the file is corrupted or the codec is not available.

We can use the ‘call me’ function, or the email function to do so successfully.

More than happy to grant access to a member of your team to have a look if they need to, I am a complete novice and we are flying by the seat of our pants - Tho hat’s off to a reasonably well designed, easy to use system!


Hi Guys,
I’m also having a similar issue (Well I think…) I have a few remote users, and they log into the Portal voicemail box, and usually just hit the speaker icon, and listen to their voicemail on their laptop. However post upgrade, they are unable to do so.

Maybe it’s a codec issues? All are set to record in ‘wav’ format, and I’ve tried to set to other formats to see what happens - so far not much.

The messages are audible if played from their physical on-site phone, and interestingly, if they select the messages (via the portal) and have them emailed to them…?


what does ‘unable to do so’ mean?

depending on the answer, any chance you could give a developer access to an account that replicates this problem?

One of yours or make a new extension, leave voicemail, confirm that it has the same issue, and then let a dev have a look to see what is going on? (And it may be necessary for them to have access to the system depending on what they find out to further investigate what the issue may be).

Sorry for the confusion! I will try to reproduce the problem and then reproduce the exact solution and then post the results.

Hello Mr. Lindheimer:


Your advice regarding wav and WAV may have helped… it was either that, or:

(Copied from PIAF Forum post)
Potential BUG Details:
History of events, in order: [New install PIAF Purple] -> [incrediblepbx18.x installer script] -> [passwd-master script] -> [update-programs script] -> [update fixes script] -> [from web gui of freepbx update to 2.9 and update all standard/extended modules].

Potential Bug, (or not): go to freepbx->Setup->General Settings->Advanced Settings then browse down to “Device Settings” and review “SIP and IAX allow” —when you hover over the setting config, a mini help menu pops up and instructs us to separate values with ‘&’ e.g. ‘ulaw&gsm&g729’ etc…
Okay, here is where it gets interesting… at least for a typical windows user in over his head :slight_smile:
{Keep in mind we haven’t made any changes except for updating freepbx to 2.9}
Go to freepbx->Setup->Extensions->701 (which was set up by the incrediblepbx18.x installer)
scroll down to Device Options and check out the “allow” field…
The hover-help pop-up gives the same info as in Advanced Settings - basically, to separate codec values use a ‘&’ between them - ie: 'h263&ulaw&gsm’
The incrediblepbx18.x installer script automagically separates the codec values with a ‘,’ instead of a ‘&’ so the default listed values ends up being ‘h263,ulaw,gsm’

So that’s my bug… or is it even a bug? Is the character mismatch between ‘,’ and ‘&’ really even a big deal?
Or is someone going to reply to this post and advise me to NOT quit my day-job? :slight_smile:
(I’m currently accepting offers of sponsorship for May’s meeting in Cleveland!)

Mr. Lindheimer, I am very willing to give precise detail to the dev team so they can see what I’ve done, what mistakes I may have made, and how I eventually corrected the Call Recording issue.
Thank you for your help~~~~~

I’m not sure how the issue with the codecs is related.

However, if someone write an upgrade script that puts commas between codecs then that is going to break any and all versions of FreePBX…

I guess I’ll have to go read the thread over in PIAF to see what people are talking about.


glad you are getting a lot of help. With that said I’m juggling several things and all the information you provided here is a bit of an information overload for me right now :frowning: But others will surely hop on board to answer some of your questions!

Let’s take it one small step at a time (my mind can only take small doses right now :slight_smile:

Go have a look at the actual files being recorded. What format are they in and are they the same as previously? I’d like to determine if it got switched on you by accident somehow. To get around browser issues, just try downloading them to your desktop of choice and use some sort of medial player (Quicktime, …)

As far as the formats, wav and WAV are different, I believe you want the ‘wav’ format for maximum playback compatibility but don’t recall.