FreePBX 2.6 Beta 2 - Come Join the Fun

If you don’t keep an eye on the regular activity via the FreePBX Timeline or other means you may not be aware of the immense activity that has been going on with FreePBX 2.6. (You mean you don’t have that bookmarked as your home page because you have real work to do?:-)

FreePBX 2.6 Beta 1 has been available for download for quite some time and so far has proven to be quite reliable. We’ve been a bit stealthy in announcing it while spending a lot of time housekeeping so that you can get a good picture of what its current state is.

You can click on the 2.6 Milestone to get a good snapshot and summary of where things are and what the current state is, and from there you can drill down to see all the tickets associated with 2.6. At the time of this writing, we show 421 closed tickets (feature requests and bugs) and only 14 open (97% complete).

The Milestone gives the best summary but some highlights included in 2.6 are provided here. One exciting addition is the option to view an Extended Online Module Repository which not only includes the standard (and new) modules that are regularly supported by the Core FreePBX team, but also includes several popular and commonly requested modules that are available but may have been hard to find in the past and more tedious to download. Some of the new modules (including those available through the Extended Repository) include:

  • Asterisk SIP Settings & Asterisk IAX Settings
  • Provides the ability to manage common global SIP and IAX settings that have often been confusing and error prone to do in configuration files, and includes a handy auto-configuration helper to determine your sip_nat.conf related settings (and further eliminates the need for that file).
  • Outbound Route Messages
  • Allows the ability to override the default “All Circuits Busy” message encountered when all trunks fail, and allows for explicit messages to be played for Emergency Routes.
  • Weak Password Checks
  • Provides an auditing function for all your SIP and IAX passwords to help harden your system and protect it from the many automated scripts on the internet seeking out and exploiting such systems. Because of the security implications, this module was also introduced earlier into version 2.5.
  • Bulk Extensions & Bulk DIDs
  • Allows you to manage or provision large quantities of users and DIDs from a spreadsheet format.
  • Custom Context & Route Permissions
  • Provide some advanced functionality to limit routes or other features and capabilities to different extensions.

There are many other enhancements such as FOP 0.30 Updated to work with Asterisk 1.6, Virtual Extensions, many Queue updates and more. Some are highlighted in the 2.6 Milestone but many more are buried in the tickets or by looking through the GUI. As always, the best way to determine what is new is to load up the new version and start to explore, and at the same time, help us validate to move it into a released state!

In the mean time, for those of you exploring the "bleeding edge", progress on FreePBX 3.0, which was announced earlier this month at ClueCon, is going great! It still remains very much a developer release, with a developer ISO currently available to check it out, but there has been a lot of dev interest which you can observe if you stop by the #freepbx-dev IRC channel (please keep in mind that channel is for development related questions and discussions, #freepbx remains the standard User channel).

For now, please hop on board and help get 2.6 out the door!

Philippe – On behalf of the FreePBX Team

It looks like many of you have discovered that shortly after blogging this I installed an Upgrade Module available if you check for updates online from 2.5.

Please report any issues you may be having in the beta forum if there are any glitches with the module. From the number of upgrades that it has triggered since publishing it though, it looks like it is probably going fairly smoothly.

Have fun with 2.6 and feel free to provide feedback!

Everything went great with the upgrade to 2.6 beta except one thing. I was intrigued by the module ‘Asterisk SIP Settings’ so I installed it. Everything stopped working. I could not send out any calls. I removed the module and everything was back to normal. I did not investigate the problem any further.

Just a head ups.


can you provide the contents of your sip_general_additional.conf file as it is when you don’t have the module installed? And then install the module (where it breaks you) and show what sip_general_additonal.conf has in it.

It would be very helpful to see what the difference is that is causing you grief. I suspect it may be the choice of default codecs that are chosen when the module is installed - we would very much like to address that.


thanks for bringing this to our attention. The module has been fixed. It turns out that if you had never accessed the GUI page and pressed submit the first time, there were no codecs populated in the module’s table. That results in ‘disallow=all’ followed by no default codecs.

The module (along with iaxsettings) had been modified to populate the standard default codecs that are populated in the initial GUI so that your issue does not happen.

See #3831 and #3832 for details.

Cool. Glad to help.

Hello All,
After the Upgrade with the Upgrade-Module I lost my iax-modems. I can see them in the Mysql-Datase and in the astdb. In the cli after “iax2 show peers” they are not visible. In the “full” I see, that they try to register, but astersik says “no such extension”. I cant make new iax-extensions. Where is the error? Thanks for help!


please bring this up in the beta forum topic and please provide a lot more details about these since there is no standard ‘iax-modem’ extension in FeePBX so you are going to need to indicate how you made these, if this is a specific distro, etc.

The Trunk issue of SIP and IAX trunks not showing up in FOP have been addressed and a new framework module has been pushed out with the required fixes to have the proper FOP configuration file generated.

I don’t think this could have any thing to do with FreePBX or the upgrade. If you can play them in a media player, it’s the same file playing that is played elsewhere. If it does not sound right, then it sounds like there is an issue on your audio player or your system?

It’s not the type of issue that FreePBX or an upgrade could likely have anything to do with that I can possibly think of.

After upgrade I can no longer listen to system recording, altho listening to extension recordings works just fine, so I know its not my quicktime.

They sound like Hal when he is restarted, slow and very low pitched, and then some fast and low pitched.

These have been recorded with *77 and sound just fine when played to the caller, just not in the browser

and I am not sure even what to look for…

ok, i thought that it could be my audio player, but it does this on 3 different machine, and 1 of those machine dont even belong to me…

but does not the recordings > call monitor use the same system to play the audio files - i can listen to those files just fine, both spawn quicktime to play the audio file, its just in system recordings its garbled - the files are fine cause i can access the file share and just double click and up they come as normal. but i can only do this while i am connected to the lan, its nice to be able to work on them remote from the machine as well.

any ideas on what to look for - its weird that one area to play audio files works, and the other does not - I see that there are 3 or 4 more ppls on the PBXIAF forms that have stated the same prob - but that was before 2.6 also - so maybe it goes back farther than that?

im willing to dig etc - just need to know what you need etc



how but staring up teh question in the forums, I’ll think about ideas and try to chime in, and that’ll help keep this thread not straying too far OT.

I did, and apparently nobody has a clue… :frowning:

Hi I upgraded to 2.6 everything is fine but in section Trunks I see no trunks. However system works fine and if I go to edit the Asterisk files I see the trunks there but not in FreePBX.

Also in modules I see Core FreePBX Newer than online version (2.6.0beta2.0) and FreePBX ARI Framework 5.5.2 FreePBX Newer than online version (

Can you please help me how to fix the issue with the Trunks? I supouse the reason is due to some changing of the name file or something?

Hi I managed to fix this issue by restoring the backups, but this had returned me to old version of freePBX.

If I upgrade Asterisk to 1.6 will it work normaly with FreePBX that I am curently running?


looks like you are using, or were using Trixbox who has forked FreePBX, primarily so they could re-brand it.

If you upgraded with the tarball it would have gotten you partway but not fully back to standard FreePBX. The issue you are running into is that trixbox has bumped their version number to 5.x so that you can not go back and get ‘genuine’ FreePBX upgrades.

One way to get around this, would be to go into the mysql database and in the ‘modules’ table, go reset the module version back (you could just set it to 0.0) and then it should allow the upgrade. I have never tried it but if you tried something like this it might work (just make sure you have a backup):

UPDATE modules SET version = '0.0' WHERE version LIKE '5.%'

That assumes that all their modules that they have bumped up are in the 5.x range. Keep in mind, if you do this, I don’t know if there will be other adverse effects. People who have tracked trixbox changes since the fork indicate that it is still nothing but branding changes though I have not bothered to pay attention so I don’t know that as a fact.

2.6 Beta lookas good and some of good features been added. I thought we stepped in …

Kiran Mummuluri


We are running on an Ubuntu 6.06.2 LTS system with Asterisk SVN-branch-1.2-r82334. Happily for us, we have a clone of the machine we keep as a hot spare. Today I upgraded the spare to 2.6 apparently without incident, but when I logged out and tried to log back in to admin screen, instead of a username/password request I received the following sad news:

SELECT username, password_sha1, extension_low, extension_high, deptname, sections FROM ampusers WHERE username = 'admin’
DB Error: no such field

Any advice would be welcome.



please start a new thread in the forums if you need further help beyond this answer.

Something went wrong in your upgrade, the ampuser table should get migrated and the clear text password that was ‘password’ migrated to an encrypted sha1 password labeled ‘password_sha1’

This is the first I have heard of the issue so something seems to be wrong with your particular install. You could try grabbing the tarball and installing it with install_amp, that should re-run the migration if you do a --force-version 2.5.0 with it.