FreePBX 2.6.0.beta2.0 - No compatible codecs, not accepting this offer!

Couldn’t place a call from one extension to another after the upgrade.

After watching CLI output to find the “No compatible codecs” warning, was able to deduce that I had to explicitly specify an “Allow” field (I choose “All” coz I can, but ymmv) in the device options for every single SIP extension.

I suppose “All” must’ve been the previous default, but now, seemingly, a blank field means “none”.

Well, I guess that’s why it’s blank… :slight_smile:

Now, if I could just figure out why “channel.c: Don’t know any of 0x0 formats” is cropping up, I might be able to make an outbound call… :open_mouth:

Good luck,


Take a look at “SIP Setting” if you installed it. I had an issue and once I did the “auto configure” things were back to normal.


all is not necessary in the device field, it should default to your general settings.

Did you have anything specific in any of the sip.conf or included custom files? Did the Asterisk SIP Settings module some how interfere with what you had setup previously and can you specific what it was set to in that module?

I believe it does a ‘disallow all’ followed by individual allows of what you setup which could be related to the issue. It would help to know what it resulted in and/or what you may have had to (or have to) change in their to know if we need to change the defaults to better align with typical setups.

Thanks for providing as much detail as possible to understand the differences.

OK - issue found and resolved:

See #3831 and #3832 for details.

To address the issue you can pull the new module and uninstall and then reinstall. Or the easier thing is simply to go to the GUI page of both and submit the page (with desired of default settings) and all will be good.