Freepbx 2.5 with Asterisk 1.6 Not Saving Voice Mail

Hi guys,
I just about have everything working with A 1.6, except that when I leave a voice message it never “gets saved”. I can leave a message an when I check that mail box there “are no new messages”. I didnt see anything wrong with the CLI output. Any input would be appriciated.

Thanks,
Sean

– <SIP/6003-099f3c78> Playing ‘vm-isonphone.ulaw’ (language ‘en’)
– <SIP/6003-099f3c78> Playing ‘vm-intro.ulaw’ (language ‘en’)
– <SIP/6003-099f3c78> Playing ‘beep.ulaw’ (language ‘en’)
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/default/6003/tmp/S08lnB format: wav49, 0xb68153d0
– x=1, open writing: /var/spool/asterisk/voicemail/default/6003/tmp/S08lnB format: gsm, 0xb686ab78
– x=2, open writing: /var/spool/asterisk/voicemail/default/6003/tmp/S08lnB format: wav, 0xb6814728
– User ended message by pressing #
– <SIP/6003-099f3c78> Playing ‘auth-thankyou.ulaw’ (language ‘en’)
– Executing [[email protected]:4] Goto(“SIP/6003-099f3c78”, “exit-SUCCESS,1”) in new stack
– Goto (macro-vm,exit-SUCCESS,1)
– Executing [[email protected]:1] GotoIf(“SIP/6003-099f3c78”, “0?exit-RETURN,1”) in new stack
– Executing [[email protected]:2] Playback(“SIP/6003-099f3c78”, “goodbye”) in new stack
– <SIP/6003-099f3c78> Playing ‘goodbye.ulaw’ (language ‘en’)
– Executing [[email protected]:3] Hangup(“SIP/6003-099f3c78”, “”) in new stack
== Spawn extension (macro-vm, exit-SUCCESS, 3) exited non-zero on ‘SIP/6003-099f3c78’ in macro ‘vm’
== Spawn extension (macro-exten-vm, s, 18) exited non-zero on ‘SIP/6003-099f3c78’ in macro ‘exten-vm’
== Spawn extension (from-internal, 6003, 1) exited non-zero on ‘SIP/6003-099f3c78’
– Executing [[email protected]:1] Macro(“SIP/6003-099f3c78”, “hangupcall”) in new stack
– Executing [[email protected]:1] ResetCDR(“SIP/6003-099f3c78”, “vw”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/6003-099f3c78”, “”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/6003-099f3c78”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“SIP/6003-099f3c78”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/6003-099f3c78”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“SIP/6003-099f3c78”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/6003-099f3c78’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on ‘SIP/6003-099f3c78’
== End MixMonitor Recording SIP/6003-099f3c78

select: all none
Datesort Time Caller ID Source Destination Context Duration Monitor
2009-04-08 16:10:59 “6003” <6003> 6003 6003 from-internal 9 sec play
2009-04-08 16:10:41 “device” <6003> 6003 *97 from-internal 1 sec
2009-04-08 16:10:01 “6003” <6003> 6003 *97 from-internal 35 sec
2009-04-08 16:09:49 “6003” <6003> 6003 6003 from-internal 10 sec play

Please see: http://freepbx.org/forum/freepbx/installation/so-you-have-a-problem-and-want-help

You did provide a call trace and that you are using some version of asterisk 1.6 but not which exact one. Also we don’t know how your system is built, etc. Please read the above link and provide all the details and maybe we can help.

A wild guess is that you have a permissions problem but without the details I can’t tell you what, where, etc…

I’m running Debian 5 and working on rewriting the Debian 4 script that was posted 8-2008. It can be found here “http://computer-ss.com/files/ul”. It is still a work in progress :slight_smile:

VER_ASTERISK=“1.6.0.8”;
VER_DAHDI=“2.1.0.4+2.1.0.2”;
VER_LIBPRI=“1.4.9”;
VER_ADDONS=“1.6.0.1”;

VER_FREEPBX=“2.5.1”;

I will get a complete trace first thing tomorrow.

many thanks,
Sean

[Apr 9 08:59:14] WARNING[2837] app_voicemail.c: Failed to obtain database object for ‘asterisk’!

I discovered the “full” log :slight_smile:

FreePBX and asterisk should not be using any database for voicemail… So you have a configuration problem someplace.

with FreePBX voicemail is done using the voicemail.conf file.

apparently the default ./configure behavior is to build comedian mail with ODBC.

I rebuilt asterisk without ODBC voicemail and it work fine now.

The only odd thing is that my 7960 phones no longer show that I have a message, I have to manually check my inbox.

changed [email protected] to
mailbox=6003
and it works

it has been a long time since I worked with Cisco 7960 phones and asterisk but that should work. If memory serves me correctly there was a trick to setting it up, try searching www.voip-info.org

Thanks a lot for your guidance! The only thing I have left to test is an IAX2 trunk and the fax to email function, then I can cleanup and post the Debian 5.0 install script :slight_smile: