FreePBX 2.11, problem with placing calls on-hold

We have FreePBX 2.11 with Asterisk 11.4.
Our phones are Snom-320.

The System is awesome and works great, has many great features. There is always that one problem that we can live with, but would rather get it solved. In our case, it is placing calls on-hold.

If I receive or place a call and push “hold” on the phone, the light blinks and I hear a new dial tone, which is what you would expect. Now, if I to hangup the receiver, one would expect that the call will remain on hold, light blinking indicating that, and I can pick up the the receiver later and poke a button and continue the conversation. Unfortunately in our case it is not the case. If I answer or place a call, then push “hold” everything is fine, but as soon as I hangup the receiver, the speaker phone gets activated with the dial tone audible. I tried to push any button that I would think can stop this to no avail. The only thing that I can do, it to call somewhere else. So the phone-set basically insists on me dialing another number or pickup the call from “hold”. Having just a quiet time is not an option.

If anyone knows what this is about and how to fix it, please let me know. I have tried old and less clever Snom-190, and it also exhibits the same behavior. This was not the case with SwitchVox system we had before we moved to FreePBX, I have not changed anything in the phones themselves except that I had to disable “RTP Encryption”.

Please help. Thank you,

I can tell you that we use a mixture of Linksys and Yealink phones. If I am on a call and press the hold button, I do not get dialtone.
I can go back and at any time, press the call appearance of the held call and get the original call back.

Thanks, I think I have figure out an acceptable work-around. I just disabled “Play Dialtone on Hold” feature in the phones settings and it is pretty much what I want now… perhaps a bodge, but the result is what I want.