FreePBX 2.11.0.23 Queue Toggle

Asterisk 11 and FreePBX 2.11.0.23

I have a queue with dynamic members. Queue is 1000

When I dial *451000 I get “agent logged out” message. I never get “agent logged in” message using *451000

I have followed this: https://wiki.asterisk.org/wiki/display/DIGIUM/FreePBX+and+Blinky+Queue+Lights

And I still only get logged out message. Is this expected> everything I have read leads me to believe I am supposed to be able to “toggle” in/out with *45xxxx

Thanks.

Disregard. Removed agent from queue manually via CLI and now this is functioning as expected.

Also apologize for basically double-posting as I mentioned this in another thread as well.

Hi guys,

This seems like the appropriate place to start, please correct me if i am wrong i’am new at this form. I am struggling with a problem i do not fully understand, i will try to explain it the best way i can.

I have a Asterisknow server, and we user Cisco SPA504G phones. I got the dynamic queue login/logout working with this syntax: *45queue. This syntax works, and it logs my phone in/out the correct queue. Now for the problem, i want the BLF to be off when logged out and on(green) when i’am logged in. But i cant get this to work, this is the syntax i am using fnc=sd;ext=*[email protected]$PROXY . I tried multiple syntaxes, but only this syntax seems to work *45queue . This is the dialplan of my cisco phone: (*xxxxxxxx[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.)

I can tell you the hint you want to be subscribed to for that BLF is 45extqueue where ext is of course the extension you want the light to be on for.

Took me some time to figure this out myself.

Hi Mark,

Thanks for the quick reply,

  • I can tell you the hint you want to be subscribed to for that - BLF is 45extqueue where ext is of course the extension you want the light to be on for.

Well thats just my problem, this syntax does not work for me, for example, if i would dial 452001000 i get a busy tone. But when i use *451000 it logs my phone in to the queue i want. It looks like the phone is doing the *45EXT part by it self.

200 = EXT
1000 = queue

Right - you don’t want to dial it, you want to “subscribe to the hint” for the blf light to work.

As stated in this post: http://www.freepbx.org/forum/freepbx/users/spa504g-with-attendant-console

“You want the keys to be setup as blf+sd mode”

I use Digium phones. When programming a button I have two settings: one is the dial setting - what the button does when pressed; the other is a “subscription” which is the “hint” that is monitored to control the behavior of the light.

Hi Mark,

I am beginning to understand how this works, but there are a few things still unclear, i hope you can/will/want to explain them to me.

200 = EXT
1000 = queue
My hints: 45[email protected] : Custom:QUEUE774*1000

Would this by the right syntax? If not could you give me a quick example of how this syntax should look like?

fnc=blf+sd;sub=45200*[email protected]$proxy;ext=*[email protected]$proxy

I’m not familiar with the syntax you are using at all - which may be because I am not familiar with those phones, or because it is incorrect. Can’t say.

Using Asterisk CLI, do: core show hints

You’ll see all the available hints. The exact syntax for the one you want should be: 452001000

That is the hint you want to subscribe to for the light to be on when extension 200 is in queue 1000. You have some extra stuff in your line - you have an extra * between *45 and the extension number. Is the @$proxy stuff specific to that model phone?

I’ve got limited experience with this and only just learned it myself - but again, using Digium phones and the DPMA.