Freepbx 15 voicemail problem


(Vcba79) #1

Hi, all

I have a freepbx 15 installation and 1 grandstream voip phone. The inbound route will direct call to grandstream phone if no one answered. The problem is: when someone call in and get into voicemail.
If he/she hand up immediately after voicemail prompt, it will leave a voicemail recorded busy tone and some garbage for 5 minutes. How can I configure voicemail not to record if phone hang up?

Thanks,


(Matthew Jensen) #2

What happens if the call is answered, but then the external caller hangs up. Assuming the Grandstream doesn’t hang up, does the call still show as active?


#3

Is your trunk, sip, digital or analog?


#4

If you have dahdi/analog trunks (which sounds likely), you need to set up ‘far-end hangup detection’ as appropriate for your locale/provider on whichever device that terminates the trunk.


(Vcba79) #5

The call is coming in from DAHDI FXO truck. I do some google work. Some talk about busy tone detect like dicko mentiond. But I can not find a way to configure it from Web UI. Or I should edit configuration file directly? Any HInt?

Thanks,


#6

If your provider doesn’t have some sort of disconnection supervision, like battery reversal or current drop, you will have to resort to tone detection for disconnection. That is configured in the config files for DAHDI and is handled by the loadzone and busydetect parameters if I recall correctly.


(Vcba79) #7

I searched my config file and found this:

grep busy *.conf
chan_dahdi_additional.conf:busycount=7
chan_dahdi_additional.conf:busydetect=no
chan_dahdi_additional.conf:busycount=7
chan_dahdi_additional.conf:busydetect=no
chan_dahdi.conf:busydetect=yes
chan_dahdi.conf:busycount=10

Is busy detect enabled or not? Is there any files


#8

It depends on which port it is enabled, but it should be enabled for FXO port in order to work. You also need to check loadzone and defaultzone parameters.


(Vcba79) #9

I saw this in chan_dahdi.conf
opermode=USA
My region is Taiwan, Should I modify this value. Will this affect DAHDI channel?

The call is coming from DAHDI FXO channel, then route to SIP phone and enter voicemail.
I did not see any busy detect in sip configuration. Should I configure sip phone to recognize
busy signal

Thanks for you help.


#10

maybe some leads here?

https://groups.google.com/forum/m/#!msg/asterisk-tw/4tOdH-9TBC0/cKWrEF2jJncJ

https://openvoxwiki.atlassian.net/wiki/spaces/UM/pages/918028/A1610P+AE1610P+on+DAHDI+User+Manual