FreePBX 15 to 16 upgrade does not work

Using either 15.0.33 (released) or 15.0.35 (edge) it fails.
Using 15.0.33 it broke installing framework, but the script kept running, finally ending by saying it completed successfully…
Ticket opened: [FREEPBX-23650] FreePBX 15 to 16 Upgrade failure - Sangoma Issue Tracker

So I reverted the snapshot and tried 15.0.35 from edge…
Nope it said not enough disk space. Some how 13.81GB is less than the required 2GB.

On a whim, I tried to pull tag 15.0.34 and it existed. Currently running the upgrade with that version, as it did not contain the disk space issue that is in 15.0.35

I won’t know if that works for an hour or so, because this step takes almost an hour on a VM with 1vCPU.

So 15.0.34 did the same as 15.0.33.

But before I reverted the snapshot, I ran the upgrade check again and it came back green, so for the hell of it I ran the upgrade again. This time the script broke the console display (broken pipe), but actually ran to completion.

The system was fully upgraded, but lost it’s registration. I did that manually with fwconsole sa activate ##### and thew system seems to be completely upgraded.

1 Like


Your PHP version of is NOT supported. You must have a version higher than or equal to 7.4

Ubuntu 20.04
I’m about to upgrade from Free PBX 15 to 16 as well! I’ve been in the process for about most of this year… Earlier it was not possible, but now it seems to be possible.

My user interface tells me that “Cannot connect to Asterisk”…
Maybe I shall also just proceed the upgrade and Asterisk will be more compatible!?
My system is currently not in “live mode”, so to speak. The system is live but we don’t use it. There are no users… so no data in such sense to loose.

You are not using the distro. So any issues you have are highly likely to be unrelated to any issues I might’ve had.

make sure that asterisk is running as the same user and group as apache2, asterisk:asterisk in both your apache2 setup and /etc/default/asterisk

Check this awesome response to my ticket…

Exactly what does any of that have to do with what I reported? The is 2 entire versions higher than was available to use on Saturday. WTF.

Of and the ticket has been punted to it being my problem… Needs information…

Isn’t it obvious? You should have waited for the unreleased version that fixes the unreported bug.


I sent Jared an email on this, but I will post it here as well. According to the ticket 2 days ago

I used versionupgrade from edge which is version 15.0.35

Looking back thru publishing records, versionupgrade ver 1.0.37 was published to edge on Jun 29 and promoted to stable on July 18. I checked the freepbx.log file on a test system set to auto updated daily, and can confirm that schedule. I don’t know how you got 15.0.35 from edge 2 days ago, is this a PBXact system?


I dumped fwconsole ma listonline to a text file and had it in my bug report. It is very clear that 15.0.33 was current.

Then I added this screenshot… Clearly I made it up…

On another system, that I did not upgrade over the weekend because of this, it is pulling 15.0.37 as current today.

I still have the snapshot from Saturday morning. I might just make a new one and then revert the system in question.

Not saying you made it up, I’m trying to figure out why you have a different result than I’m seeing. From a test system of mine

/var/log/asterisk/freepbx.log-20220611:[2022-06-01 07:04:41] [freepbx.INFO]: Module: versionupgrade Updated to version 15.0.33 [] []
/var/log/asterisk/freepbx.log-20220626:[2022-06-15 08:22:16] [freepbx.INFO]: Module: versionupgrade Updated to version 15.0.34 [] []
/var/log/asterisk/freepbx.log-20220626:[2022-06-21 17:27:43] [freepbx.INFO]: Module: versionupgrade Updated to version 15.0.35 [] []
/var/log/asterisk/freepbx.log-20220711:[2022-06-30 08:19:41] [freepbx.INFO]: Module: versionupgrade Updated to version 15.0.37 [] []

Possible a repo issue, but I’m seeing the same versions in both mirror1 and with mirror, at least as of today. I will chase with engineering.

1 Like

I’ve checked and the database passwords are the same.

I’ll make a snapshot before upgrading…
To do the upgrade, will it be possible just to type:

sudo fwconsole versionupgrade

When logging on to the service with the web-interface, “FreePBX Administration”, the error message shows, “Cannot Connect to Asterisk”.
Maybe I need to fix that first!? But… I was really wishing for the upgrade to be fixing it for me…!

If there is a problem with Asterisk running, the upgrade is unlikely to fix your issue.

Because you are running on a non distro system the upgrade module may or may not work as it won’t have been tested.

You might be better to start a fresh v16 and restore a config backup and do it that way.

Thank you! Please guide me! Why Asterisk 16 when there is an Asterisk 18 LTS available?
The server is live but there is no user data since it’s currently yet not in use.


The asterisk version is dependant on what you selected on install.

You can run asterisk-version-switch to upgrade if you would like. If Asterisk isn’t running, try running fwconsole restart.

This is sort of embarrassing…! We were in-fact actually running Asterisk 18…
We uninstalled some PHP packages, compiled the source for Asterisk 18 again and installed. Now it’s running without the error showing.

Question remains! Upgrade FreePBX from 15 to 16, Yes or no? Is it worht the effort? What’s the difference?

Make your own thread, none of this had anything to do with the original post.

@lgaetz Well this is not a unique issue, and I do not care how long module X has been in stable/edge/whatever. I don’t get how Sangoma can just ignore my post as “upgrade works use current module,” when I was using the most current thing the system would give me.

Further proof with this being a problem… Two totally different PBX systems than the one above.
Today, I have one FreePBX 16 system that was FreePBX 15 and upgraded to FreePBX 16. Another is a brand new installed FreePBX 16 to be a warm spare for DR purposes.

Both systems have all yum updates applied, and have all module updated. Yet look wtf is happening here… Conferences pro is not the same version. The original system shows 16.0.4 but the DR system shows 16.0.9. I have not even configured backup and warm spare, etc yet. This was found because prior to starting I always make sure the installed modules on the new DR system match what is installed on the original. Save headaches later.


Both are on the same MODULE_REPO

Also MODULEADMINWGET is the same.

So why are they not showing the same information?

The simple logical answer? Your mirrors suck. They are probably not being kept in sync properly. Likely the same problem I had 1.5 weeks ago when I tried to upgrade the system that started this thread.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.