Freepbx 15 release version Backup fails to start Invalid argument supplied for foreach()

Just completed the upgrade of a sng7 freepbx 14 to 15
Installation went smoothly, updated all relevant modules and then tried backup
(which was never used before)
asterisk 16.6.2
Linux fpbx.local 3.10.0-957.21.3.el7.x86_64 #1 SMP Tue Jun 18 16:35:19 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
php -v
PHP 5.6.40 (cli) (built: Jan 22 2019 23:51:52)
Copyright © 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright © 1998-2016 Zend Technologies
with Zend Guard Loader v3.3, Copyright © 1998-2014, by Zend Technologies
with Zend OPcache v7.0.4-dev, Copyright © 1999-2015, by Zend Technologies

    Running with: /usr/sbin/fwconsole backup --backup='8ff79af5-e5bb-47f5-8c40-fa1be814b5f1' --transaction='c810b503-9308-481f-a5f7-ac679c74647f' >> /var/log/asterisk/backup_c810b503-9308-481f-a5f7-ac679c74647f_out.log 2> /var/log/asterisk/backup_c810b503-9308-481f-a5f7-ac679c74647f_err.log & echo $!
Running Backup ID: 8ff79af5-e5bb-47f5-8c40-fa1be814b5f1
Transaction: c810b503-9308-481f-a5f7-ac679c74647f
Starting backup Default_backup
This backup will be stored locally and is subject to maintenance settings
Storage Location: /var/spool/asterisk/backup/Default_backup/20191208-092630-1575789990-

In Multiple.php line 149:
  Invalid argument supplied for foreach()  

backup [--backup BACKUP] [--externbackup EXTERNBACKUP] [--dumpextern DUMPEXTERN] [--transaction TRANSACTION] [--list] [--warmspare] [--implemented] [--filestore FILESTORE] [--restore RESTORE] [--restorelegacycdr] [--modules MODULES] [--restoresingle RESTORESINGLE] [--backupsingle BACKUPSINGLE] [--singlesaveto SINGLESAVETO] [--b64import B64IMPORT] [--fallback]

Please try with latest edge release of backup module.

backup |


Continuing the discussion from Freepbx 15 release version Backup fails to start Invalid argument supplied for foreach():

Have updated to 15.08.77 as latest edge
Same issue
However I now know what the problem is.
Default backup comes with 0 modules, which crashes foreach when tried.
Now if one edits default job, select all, then it works
And does not allow you to return to 0 modules too.
So its an initial conditions issue carried over from default job.

can you file a bug ticket pls:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.