FreePbx 15 on centos 8 after installation debug, need help on this error message: the gateway did not receive a timely response from the upstream server or application


(Dario) #1


after freepbx 15 installation on centos 8 following the official guide. Once connecting to the web admin GUI, after a minute or maybe more the page load and it appear for some seconds this message: the gateway did not receive a timely response from the upstream server or application.
I don’t know how to solve this problem to debug it…
Any help will be apreciated.
thanks


(Shahin Nazir) #2

Hi @DarBus
First you did not give us information about which modules are install or maybe you have some broken modules and waiting update modules on the your PBX List.
Pls try to list first yours PBX Modules and check there Status. You must see Enabled or Not Installed.

fwconsole ma list

Then you should see try to upgrade all modules with signatures.

fwconsole ma refreshsignatures
fwconsole ma upgradeall

Or if you doesn’t use or not planing to use Vega Gateway module you can remove it.

fwconsole ma remove vega


(Dario) #3

I have updated freepbx…but the problem still persist. Don’t know the reason.
In freepbx log

THERE’RE LOT OF THOSE MESSAGES:
Deprecated way to add Console commands for module voicemail, adding console commands this way can have negative performance impacts. Please use module.xml.
±-----------------±-----------±---------±--------+
| Module | Versione | Status | License |
±-----------------±-----------±---------±--------+
| builtin | | Attivato | |
| callrecording | 15.0.7.11 | Attivato | AGPLv3+ |
| cdr | 15.0.17 | Attivato | GPLv3+ |
| conferences | 15.0.7.4 | Attivato | GPLv3+ |
| core | 15.0.12.11 | Attivato | GPLv3+ |
| customappsreg | 15.0.13 | Attivato | GPLv3+ |
| dashboard | 15.0.5 | Attivato | AGPLv3+ |
| featurecodeadmin | 13.0.6.4 | Attivato | GPLv3+ |
| framework | 15.0.16.56 | Attivato | GPLv2+ |
| infoservices | 15.0.2 | Attivato | GPLv2+ |
| logfiles | 13.0.10.8 | Attivato | GPLv3+ |
| music | 15.0.20 | Attivato | GPLv3+ |
| pm2 | 15.0.3.7 | Attivato | AGPLv3+ |
| recordings | 15.0.3.13 | Attivato | GPLv3+ |
| sipsettings | 15.0.6.27 | Attivato | AGPLv3+ |
| soundlang | 15.0.5.7 | Attivato | GPLv3+ |
| voicemail | 15.0.18.15 | Attivato | GPLv3+ |
±-----------------±-----------±---------±--------+


(Shahin Nazir) #4

@DarBus
Pls try to re-install Vega GW module.

fwconsole ma downloadinstall vega


(Dario) #5

The command exit saying:
The followint error occured:
-Retrieved Module XML Was Empty

And what about the freepbx.log messages?


(Dario) #6

theese are the freepbx logs. See that freepbx.log is full of thash messages…that’s increase very rapidly the size of the log…in less than one week is more than one mb.
I can’t upoload or link file logs in this forum :frowning:


#7

Paste the relevant section of the log at https://pastebin.freepbx.org and post the link here.


(Dario) #8

https://pastebin.freepbx.org/view/80688b5e


(system) closed #9

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.