Freepbx 15 not answerin main line


(Canada) #1

We used to have the freepbx worked but now when we calling
It does not answer when I call our office mainline (no ring)

Eventually gets a busy signal after about 7 seconds
I look at /etc/var/log/astrisk /full log does not get any updates when I called the last log entry is

3:30pm and I made a called at 4:03pm


(Itzik) #2

You’ll have to provide more info.

Is this PBX behind NAT? if so, how is the Trunk registered? Etc etc etc

Your inbound route goes where?

When you say you see nothing in the full log:

  • Is the time correct? Maybe the time is off so you are looking at the wrong lines.
  • You see nothing, or nothing that you think is relevant?

(Canada) #3

PBX is not behind a NAT
inbound route is as follows

yes the time is correct it never updates no matter how many times I call

There nothing relative that shows up in this log


(Yf) #4

Did this ever work?
From cli asterisk -vvvvr does it show anything?
Sip set debug on , does that show anything?( Eg 401 forbidden)
Last, tcpdump does that show trunk packets?


(Canada) #5

yes it did worked
when I do the astrisk command a prompt shows up I kind new to frepbx so not sure what to do next

I not sure how to turn on sip debug

finally I have tried tcpdump and no VOIP packet show up


(Canada) #6

update I figure to turn on sip debug but as far I can tell it does not add thing to he full log or any new files to /var/log/asterisk folder


(Itzik) #7

Open the Asterisk CLI

asterisk -rvvvvv

And then If you are using ChanSIP run

sip set debug on

Or if PJSIP

pjsip set logger on

Try calling the number, and see if you see anything in the console.


(Canada) #10

here the log I even tried it twice this what happens when I call

VERBOSE[3095] res_pjsip_logger.c: <— Transmitting SIP request (413 bytes) to UDP:10.12.6.210:5383 —>
OPTIONS sip:210@10.x.x.21:5383 SIP/2.0
Via: SIP/2.0/UDP 10.x.x.50:5060;rport;branch=z9hG4bKPjaa5f8e71-799d-4598-b0e4-8d322003d9d4
From: sip:210@10.x.x.100;tag=7c5ebdb5-51f9-4f8f-834e-9ade6c7075f3
To: sip:210@10.x.x.21
Contact: sip:210@10.x.x.50:5060
Call-ID: e26062e7-f8dc-4cd8-814e-e9f94055c8fc
CSeq: 19354 OPTIONS
Max-Forwards: 70
User-Agent: FPBX-15.0.16.70(15.7.3)
Content-Length: 0

[2020-07-30 11:17:39] VERBOSE[3094] res_pjsip_logger.c: <— Received SIP response (540 bytes) from UDP:10.12.6.210:5383 —>
SIP/2.0 200 OK
Via: SIP/2.0/UDP 10.12.6.50:5060;rport=5060;branch=z9hG4bKPjaa5f8e71-799d-4598-b0e4-8d322003d9d4
From: sip:210@10.x.x.100;tag=7c5ebdb5-51f9-4f8f-834e-9ade6c7075f3
To: sip:210@10.12.6.210;tag=583113289
Call-ID: e26062e7-f8dc-4cd8-814e-e9f94055c8fc
CSeq: 19354 OPTIONS
Contact: sip:210@10.x.x.x:5383
Supported: 100rel, replaces, timer
Allow: INVITE, ACK, OPTIONS, BYE, CANCEL, REFER, NOTIFY, INFO, PRACK, UPDATE, MESSAGE
Accept: application/sdp, message/sipfrag, application/dtmf-relay
Content-Length: 0


(Itzik) #11

This doesn’t say anything about an incoming call attempt, which indicates that your SIP Provider cannot reach the PBX.
Either your Trunk is offline, or there’s no ports forwarded.


(Canada) #12

yes there where a bunch route issues and just spoke to gateway end point and our box is not in there arp tables. We just fix the issues so I assuming it going take time for them to update arp tables