FreePBX 14 UCP Phone and Responsive Firewall

For some reason Responsive Firewall only works with hard phones and soft phones. But when I log into the UCP and try using the phone module in there, RF will not automatically add it into exclusions like it always does with hard and soft phones. Is RF not designed to add the UCP phone as well? I have to manually add the IP to a trusted zone in order for the UCP phone to work.

Any ideas why?

UCP is supposed to set up the network access of the UCP client once the user logs in. If this isn’t the case (we need logs) then there might be a bug. Not likely, because this code is working flawlessly lots of places, but it could be.

The thing is, you won’t even have access to the web of freepbx if you’re not already in thr trusted zone. I temporarily opened port 443 to be able to access the web from anywhere. That way my ip doesn’t have to be in the trusted zone to access ucp. So when i go to the UCP and try to use the phone, RF doesn’t make access to it although it shows registered. But when i try to make a call UCP phone disconnects amd says Connecting to socket.

If you are opening 443 than you also need to open the port for WebRTC as defined in advanced settings the WSS port

Thanks Tony. Will try that.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.