FreePBX 14 to 16 can't register extensions

I was running 14 on an MSI indstrial PC for a couple of years in my home office system to allow me to:

  1. get familiar with FreePBX
  2. test integration with various control systems

About a year ago the MSI SSD failed and despite regular backups onto my Synology NAS I was never able to get the MSI working with a new SSD. I gave up on it until recently and bought a Gigabyte Brix i7 with a view to getting FreePBX running again.

Installed FreePBX 16 on the Gigabyte and have been able to provision all my Snom extensions no problem.

However, I have a Polycom VVX-600 in my office that will not register. The config in the Polycom had not changed since the MSI died so should only have been a case of changing the password to match the extension in the new 16 FreePBX. The extension # and user are the same as the old 14 FreePBX. I’ve managed to get it to register once but when i turned my office back on the following day the phone became unregistered and has not been able to connect since. I’ve googled and tried all sorts, even factory defaulted the phone but no joy.

I also have 4 Crestron TSW touchpanels that worked fine on 14 but will not register on 16.
There is not much to set in these just the SIP server IP, extension, user and pw.

I suspect these may have been connecting to 14 using chan_sip and it looks like 16 does not install this by default. I have since installed this and set the touchpanel extensions to chan_sip but to no avail.

Would really appreciate any advice to get these last 5 devices registered.


You probably want to stick to chan_pjsip as chan_sip is going away. It shouldn’t matter to the phones what protocol you are using as long as they are trying to connect to the correct UDP port. By default on new isntallations pjsip should listen on port 5060. Confirm that you have all the IPs and ports configured correctly on the phones before you proceed on troubleshooting anything else.

Hi Igor,

All ports are 5060 and Transport on all devices is UDP.

I’ll remove chan_sip if it is going away and have another go.

Frustrating as all the Snom phones connected as soon as i added the extensions in FreePBX and changed the passwords in the phones. The Polycom and Crestron panels are being a total PIA.


Make sure all the extensions are set to be pjsip extensions before you remove chan_sip. Another troubleshooting step would be to just recreate the extension wholesale and update the configuration on the phones if it’s only the one or two that you are trying to get to work.

If you are running both pjsip and chan_sip, that is not possible. The value of Port to Listen On (for pjsip) and the value of Bind Port (for chan_sip) must be different.

Of course, your device must register to the port being used by the channel driver the extension is using.

OK, so basically I’m a bit rusty on FreePBX having not used it for a while.

I got the Crestron touchpanels working.
These sit on my Automation VLAN-10.

I added the Automation VLAN to Firewall>Networks and they connected straight away.

FreePBX sits on my Voice VLAN-2 along with all the phones. I hosed the Polycom extension and user from the PBX and added again. Then added the Voice VLAN to the Firewall>Networks and the Polycom registered.

So, I don’t know why the Snoms registered and the Polycom did not. Can now make calls and as an added bonus, the Polycom camera now routes to the Crestron panels. This did not work before.

Now i can start setting the rest of this up.


You also want to check the Asterisk SIP Settings section and make sure that any of your VLAN subnets that will have SIP devices connecting to the PBX are added to the Local Networks section.

Thanks Igor,

Very helpful.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.