FreePBX 14 RC1 and Sangoma s500 - Register Failed

I have a fresh v14 RC1 install and a brand new s500 Sangoma phone. I’m new to FreePBX.

I go to Applications->Extensions->Add Extension, where I’ve tried Chan_SIP and PJSIP. I enter the User Extension, Display Name, Outbound CID and have it create a new user. I copy the password for the new user so that I can use it when configuring the phone. Then, I click submit to create the extension.

I then connect to the s500 via a browser and go to Account->Basic. I enter the Primary SIP Server address, put in the SIP User ID, Authenticate ID, and password. Then, I click SaveSet.

The page refreshes after a bit, but then shows Account Status as “Register Failed”.

Again, I’m new to this. Is there something I’m doing wrong related to new phone setup? I did change the SIP Port to 5160 for Chan_SIP and made sure it was 5060 for PJSIP. But, I still get the same results. Also, the password I am copying and using in the phone config is the “Password for new user” in User Manager Settings.


That wont ever work. Please follow the guide here for Sangoma Phones otherwise if you manually try to configure it you will loose lots of features.