Freepbx 14 -> Provisioning Protocols - Http Authentication not working

Using: Freepbx 14 Distro, Asterisk 13, latest Sysadmin edge

I have HTTP Authentication setup for HTTP provisioning and it was working on Freepbx right before the upgrade but since the upgrade to Freepbx 14 Sysadmin -> Provisioning Protocols -> HTTP Authentication does not work. I tried setting it to “none” then back on “both” to try and refresh it but it did nothing. It will not require a password before downloading configs.

Has anyone else noticed this or found a fix to this?

My first thought on this was “I wonder if he’s using the full URL for provisioning, including the port number.”

I’m sure you’ve already tried all of that, but there’s a nagging bit that reminds me that someone was having a similar problem until they included the provisioning port (:83) on the URL.

I get the correct file every time, the problem is it lacks the authentication check. We use the authentication check as part of our security setup.

I made an issue ticket about this and it got fixed in the edge (Might be release when you read this) module:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.