FreePBX 14 - One last question (for me at least)

Ok - So far every problem I had has been fixed by the helpful community here - I am using this on all Vritual Machines, so this is not a problem per se, but I would like to fix it - it just looks like something is wrong - When I do a yum check (or when I add or remove or update anything) I get the following errors:

kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__class_create) = (‘0’, ‘0xa2654165’, None)
kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__init_waitqueue_head) = (‘0’, ‘0xffc7c184’, None)
kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__kmalloc) = (‘0’, ‘0x5a34a45c’, None)
kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__mutex_init) = (‘0’, ‘0x4bf79039’, None)
kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__per_cpu_offset) = (‘0’, ‘0x32047ad5’, None)
kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__register_chrdev) = (‘0’, ‘0xfa0d49c7’, None)
kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__request_module) = (‘0’, ‘0xe90dcae0’, None)
kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__tracepoint_module_get) = (‘0’, ‘0xacdeb154’, None)
kmod-dahdi-linux-2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64.x86_64 has missing requires of kernel(__wake_up) = (‘0’, ‘0x642e54ac’, None)

and about 100 more of the same type - from the tagging, it looks like it still has the dahdi kernel modules for CentOS 6 and the 2.6 Kernel, but when I look in the repo’s, I can see no newer kmod-dahdi-linux anything - Am I missing a repo or tagged to the wrong repo? If I try to remove it, it want’s to remove dependencies that I think I really need like so:

[[email protected] ~]# yum remove kmod-dahdi-linux
Loaded plugins: fastestmirror, kmod
Resolving Dependencies
–> Running transaction check
—> Package kmod-dahdi-linux.x86_64 0:2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64 will be erased
–> Processing Dependency: kmod-dahdi-linux for package: dahdi-linux-2.11.1-1.26.sng.x86_64
–> Processing Dependency: kmod-dahdi-linux for package: freepbx-14.1-1.sng7.noarch
–> Running transaction check
—> Package dahdi-linux.x86_64 0:2.11.1-1.26.sng will be erased
–> Processing Dependency: dahdi-linux for package: dahdi-tools-2.11.1-1.23.sng.x86_64
–> Processing Dependency: dahdi-linux for package: libopenr2-1.3.4-1.6.sng.x86_64
–> Processing Dependency: dahdi-linux for package: schmooze-dahdi-1.0.0-2.noarch
—> Package freepbx.noarch 0:14.1-1.sng7 will be erased
–> Running transaction check
—> Package dahdi-tools.x86_64 0:2.11.1-1.23.sng will be erased
—> Package libopenr2.x86_64 0:1.3.4-1.6.sng will be erased
—> Package schmooze-dahdi.noarch 0:1.0.0-2 will be erased
–> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================================================================================
Package Arch Version Repository Size

Removing:
kmod-dahdi-linux x86_64 2.11.1-22_centos6.2.6.32_642.6.2.el6.x86_64 @anaconda-SHMZ-201501302108.x86_64/6.6 27 M
Removing for dependencies:
dahdi-linux x86_64 2.11.1-1.26.sng installed 2.6 M
dahdi-tools x86_64 2.11.1-1.23.sng installed 904 k
freepbx noarch 14.1-1.sng7 @sng-pkgs 163 M
libopenr2 x86_64 1.3.4-1.6.sng installed 170 k
schmooze-dahdi noarch 1.0.0-2 @anaconda-SHMZ-201501302108.x86_64/6.6 766

Transaction Summary

Remove 1 Package (+5 Dependent packages)

Installed size: 194 M
Is this ok [y/N]:

which seems like a bad idea to me - any thoughts on clearing this error?

Hi Greg,

If you want to update it to the Sangoma 7 version, please do this

yum shell
erase kmod-dahdi-linux
install kmod-dahdi-linux
ts solve
ts run

(edit: The Jira comment this comes from is https://issues.freepbx.org/browse/FREEPBX-15491?focusedCommentId=108399&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-108399)

This is what @GameGamer43 told me to do to fix my DAHDI problem… In your case you don’t need DAHDI but that will make sure you have the right version for Sangoma 7…

I would have liked to refer you to the ticket but I can’t seem to find the way to refer to a specific jira comment from my mobile phone… (edit: I added it once I got home…)

The ticket URL is https://issues.freepbx.org/browse/FREEPBX-15491. I was one of the initial testers so there are quite a few issues there, some of which you had like the CDR problem…

Good luck and have a nice day,

Nick

3 Likes

Fantastic - Worked like a charm!

Thanks!

Hi!

You are welcome!

Nick