FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX 14 GUI not loading after time period


(Lucas Ryan) #1

I just installed a fresh instance of FreePBX14. It works great, but ever since I installed it, for the last couple of days, if I try to access the web GUI in the morning, it just sits there, not responsive, and does not load at all. I can SSH to the box, as well as still make/receive phone calls, but the GUI is non responsive.
Logging in via SSH and restarting Apache (which takes about a full minute to restart) then makes the GUI responsive again and accessible.

Has anyone else experienced this with FreePBX 14?


#2

Nope.

Maybe checkout the contents of /var/log/httpd/error_log for any errors


(Dave Burgess) #3

Does this sound familiar?


#4

This is almost certainly related to the bug I submitted here (FREEPBX-19926). Sangoma didn’t want to spend the time to dig into this deeper and the fix Andrew applied had no impact. In short, you simply can’t leave any browser window open to the Dashboard for more than about 4 hours or things start timing out and that crashes apache. You have to pkill httpd and restart it to get the GUI (Admin, UCP, etc) up again.


(Lucas Ryan) #5

I’ll give it a “test” today/tonight (without having the browser opened) and see if I experience the same issue.

Regarding the last comments from Sangoma, that’s not very encouraging to hear. I’m looking to update some PBXs from FreePBX 13, which has been stable for me, and never had this timeout issue before, to FreePBX 14. The fact is, I often leave a Chrome tab open to a PBX for hours at a time. Now, if I do this, it will lock up the web GUI?!? That’s not encouraging…


(Lucas Ryan) #6

So as of this morning, everything is working properly. I intentionally left a browser window open to the PBX overnight. I will continue to test over the weekend.


#7

It only happens if you leave the GUI open on the Dashboard, as this uses various script to constantly update things like the Live Network Usage. In fact, it would appear the Live Network Usage is the culprit. Unfortunately, there is no option to turn this widget off on the Dashboard…I, personally, find it distracting, as even updating the Dashboard on a completely idle system is going to show as spikes of activity in that widget (for obvious reasons). If Sangoma isn’t going to seriously look into it, then we should at least be given the option to disable the offending widget from the Dashboard entirely. Frankly, the Dashboard is due for some re-write love, as it is entirely too static in nature for its name.


(Lucas Ryan) #8

That’s good to know. Hopefully this can be resolved soon. I’ll keep an eye out for this.


#9

One might add that any “statistics” panel without any x or y index is also kinda dumb so should also be turn-offable, no?


#10

Yeah, pretty much. The Dashboard needs quite a bit of work…turns out that even turning off stats collection doesn’t seem to be working as intended; cron still runs, which kinda defeats the point of turning it off. {shrugs}

Tho, I suspect most of these minor issues will go ignored for quite a while. Most of our loyal FPBX devs are gone now and the new folks on board from Digium seem to have their own priorities (asterisk and other Digium products). Who knows what future prioritization will look like. It’s anyone’s guess now.