FreePBX 14.0.1beta10 breaking things


I upgraded Framework module from 14.0.1beta9 to 14.0.1beta10 and things are broken. It was the only thing I upgraded.

Logout and login doesn’t seem to work. Tab links do not seem to function properly. The latter makes me wonder how I will be able to apply a fix when one if deployed.

2 reboots and still the same behavior.

Need more information please. Really have no idea what is wrong without screenshots or something to go on other than “things”

Edit: Just checked two systems. A development machine and a live machine and both are fine. No issues.

@tm1000, as I said, tabs don’t seem to be working. For example, when I go to admin>updates clicking on “Module Updates” doesn’t navigate anywhere even though url is apended (see picture). I discovered this behavior trying to go to Connectivity>Trunks “Sip Settings.”

I then attempted to log out and then in again only to find that it would process the logout. I then attempted to login on several browsers (chrome canary, firefox, edge) to no affect; login prompt does not popup.

I’ve also attached a picture of my dashboard. It usually looks like that, but doesn’t have all of these problems. Are any of those things a concern?

ssh into your machine and run:

fwconsole ma upgrade framework

1 Like

@tm1000 that worked! Thank you!

And thank you for your work on the project overall. Noticed you updated the changelog today. Thanks for everything!

1 Like