FreePBX 14.0.11 doesn't pass the extension on INCOMING calls

Hi Guys,

I’m trying to set up a MIXMON_POST in the Global conf to run a script but I’m not getting the extension number instead, I’m getting the queue number for INCOMING calls.

This is how the line looks like: MIXMON_POST = /usr/share/asterisk/agi-bin/ ^{MIXMONITOR_FILENAME} “^{AMPUSER}” ^{CALLERID(number)} ^{CDR(dst)} ^{CDR(start)} ^{CDR(src)} ^{UNIQUEID} “^{AGENTEXTEN}”

Note: I’m able to get the extension for OUTGOING calls but there are no extensions for INCOMING calls.

Any help will be really appreciated

Thank you

You are the second person this week that is asking about this script and the variables. So I got curious and looked it up, Call Cabinet. It seems to have a screen shot of the Advanced Settings section from FreePBX v11/v12 so that is something.

You’ll never get this variable as it is a channel variable of Chan_Agent (had to do a little digging for it) and FreePBX does not use it. It’s a no-load module, which means you can enable it but then you’ll have to setup agents.conf and update the dialplan to call on the channel properly.

This is a FreePBX setting. AMPUSER is used to store the user’s id (extension) so it can look in the AstDB for user and device settings for the extension. When an inbound call is hitting the PBX there really isn’t an AMPUSER because DIDs are not users.

It would appear this is counting on AGENTEXTEN to be what tells you the extension for inbound calls but it requires the ACD (Chan_Agent) to be configured.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.