FreePBX 14.0.1.20 SIP Trunk

I have a brand new FreePBX Server that I am trying to configure. My previous FreePBX server is having issues so I am manually configuring the new server with the same settings on the old server.

I have noticed that on this version of Asterisk 13.17.2 chan_sip has been replaced with pjsip and is the biggest struggle for me at the present time in regards to my SIP Trunks.

Currently I have created a chan_sip trunk with the settings from the old server. I am able to receive inbound calls on all of the numbers of this trunk. On dialing out to any number I am getting All Circuits are busy

Here is a copy of the output when dialing out

  • <PJSIP/108-00000002>AGI Script sangomacrm.agi completed, returning 0
    – Executing [[email protected]:24] Set(“PJSIP/108-00000002”, “CHANNEL(hangup_handler_push)=crm-hangup,s,1”) in new stack
    – Executing [[email protected]:25] NoOp(“PJSIP/108-00000002”, “CRM Finished”) in new stack
    – Executing [[email protected]:26] GotoIf(“PJSIP/108-00000002”, “0?bypass,1”) in new stack
    – Executing [[email protected]:27] ExecIf(“PJSIP/108-00000002”, “1?Set(CONNECTEDLINE(num,i)=574xxxxxxx”) in new stack
    – Executing [[email protected]:28] ExecIf(“PJSIP/108-00000002”, “1?Set(CONNECTEDLINE(name,i)=CID:5742540111)”) in new stack
    – Executing [[email protected]:29] ExecIf(“PJSIP/108-00000002”, “0?Set(CONNECTEDLINE(name,i)=CID:(Hidden)5742540111)”) in new stack
    – Executing [[email protected]:30] GotoIf(“PJSIP/108-00000002”, “0?customtrunk”) in new stack
    – Executing [[email protected]:31] Dial(“PJSIP/108-00000002”, “SIP/SoTelRegistrationOutgoing/574261xxxx,300,T”) in new stack
    == Using SIP RTP TOS bits 184
    == Using SIP RTP CoS mark 5
    [2017-12-13 14:47:18] ERROR[19176][C-00000001]: netsock2.c:305 ast_sockaddr_resolve: getaddrinfo(“SoTelRegistrationOutgoing”, “(null)”, …): Name or service not known
    [2017-12-13 14:47:18] WARNING[19176][C-00000001]: chan_sip.c:6320 create_addr: No such host: SoTelRegistrationOutgoing
    [2017-12-13 14:47:18] WARNING[19176][C-00000001]: app_dial.c:2525 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
    == Everyone is busy/congested at this time (1:0/0/1)
    – Executing [[email protected]:32] NoOp(“PJSIP/108-00000002”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 20”) in new stack
    – Executing [[email protected]:33] GotoIf(“PJSIP/108-00000002”, “0?continue,1:s-CHANUNAVAIL,1”) in new stack
    – Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
    – Executing [[email protected]:1] Set(“PJSIP/108-00000002”, “RC=20”) in new stack
    – Executing [[email protected]:2] Goto(“PJSIP/108-00000002”, “20,1”) in new stack
    – Goto (macro-dialout-trunk,20,1)
    – Executing [[email protected]:1] Goto(“PJSIP/108-00000002”, “continue,1”) in new stack
    – Goto (macro-dialout-trunk,continue,1)
    – Executing [[email protected]:1] NoOp(“PJSIP/108-00000002”, “TRUNK Dial failed due to CHANUNAVAIL HANGUPCAUSE: 20 - failing through to other trunks”) in new stack
    – Executing [[email protected]:2] ExecIf(“PJSIP/108-00000002”, “1?Set(CALLERID(number)=108)”) in new stack
    – Executing [[email protected]:8] Macro(“PJSIP/108-00000002”, “outisbusy,”) in new stack
    – Executing [[email protected]:1] Progress(“PJSIP/108-00000002”, “”) in new stack
    – Executing [[email protected]:2] GotoIf(“PJSIP/108-00000002”, “0?emergency,1”) in new stack
    – Executing [[email protected]:3] GotoIf(“PJSIP/108-00000002”, “0?intracompany,1”) in new stack
    – Executing [[email protected]:4] Playback(“PJSIP/108-00000002”, “all-circuits-busy-now&please-try-call-later, noanswer”) in new stack
    – <PJSIP/108-00000002> Playing ‘all-circuits-busy-now.g722’ (language ‘en’)
    > 0x7f9b58019680 – Strict RTP learning after remote address set to: 172.16.253.4:16500
    > 0x7f9b58019680 – Strict RTP switching to RTP target address 172.16.253.4:16500 as source

Things I do not understand. Within the chan_sip settings of the trunk it asks for Trunk Name on Outgoing. I use the same name from the old server and it is trying to do a DNS Lookup of this name which is not valid. Since the provider is using SRV records, I have tried to replace the trunk name on outgoing with the host entry of the sip settings and get the same result with a different message

– Executing [[email protected]:24] Set(“PJSIP/108-00000005”, “CHANNEL(hangup_handler_push)=crm-hangup,s,1”) in new stack
– Executing [[email protected]:25] NoOp(“PJSIP/108-00000005”, “CRM Finished”) in new stack
– Executing [[email protected]:26] GotoIf(“PJSIP/108-00000005”, “0?bypass,1”) in new stack
– Executing [[email protected]:27] ExecIf(“PJSIP/108-00000005”, “1?Set(CONNECTEDLINE(num,i)=5742614839)”) in new stack
– Executing [[email protected]:28] ExecIf(“PJSIP/108-00000005”, “1?Set(CONNECTEDLINE(name,i)=CID:5742540111)”) in new stack
– Executing [[email protected]:29] ExecIf(“PJSIP/108-00000005”, “0?Set(CONNECTEDLINE(name,i)=CID:(Hidden)5742540111)”) in new stack
– Executing [[email protected]:30] GotoIf(“PJSIP/108-00000005”, “0?customtrunk”) in new stack
– Executing [[email protected]:31] Dial(“PJSIP/108-00000005”, “SIP/voip.sotelsystems.com/574261xxxx,300,T”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/voip.sotelsystems.com/5742614839
[2017-12-13 14:51:59] NOTICE[18946][C-00000003]: chan_sip.c:23996 handle_response_invite: Failed to authenticate on INVITE to ‘sip:[email protected]:5160;tag=as4d93509b’
– SIP/voip.sotelsystems.com-00000002 is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)

The External IP Address of the server is the 165.138.207.10

== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
[2017-12-13 16:05:23] ERROR[14778][C-00000001]: netsock2.c:305 ast_sockaddr_resolve: getaddrinfo(“SoTelRegistrationOutgoing”, “(null)”, …): Name or service not known
[2017-12-13 16:05:23] WARNING[14778][C-00000001]: chan_sip.c:6320 create_addr: No such host: SoTelRegistrationOutgoing
[2017-12-13 16:05:23] WARNING[14778][C-00000001]: app_dial.c:2525 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:32] NoOp(“SIP/108-00000002”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 20”) in new stack
– Executing [[email protected]:33] GotoIf(“SIP/108-00000002”, “0?continue,1:s-CHANUNAVAIL,1”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
– Executing [[email protected]:1] Set(“SIP/108-00000002”, “RC=20”) in new stack
– Executing [[email protected]:2] Goto(“SIP/108-00000002”, “20,1”) in new stack
– Goto (macro-dialout-trunk,20,1)
– Executing [[email protected]:1] Goto(“SIP/108-00000002”, “continue,1”) in new stack
– Goto (macro-dialout-trunk,continue,1)
– Executing [[email protected]:1] NoOp(“SIP/108-00000002”, “TRUNK Dial failed due to CHANUNAVAIL HANGUPCAUSE: 20 - failing through to other trunks”) in new stack
– Executing [[email protected]:2] ExecIf(“SIP/108-00000002”, “1?Set(CALLERID(number)=108)”) in new stack
– Executing [[email protected]:8] Macro(“SIP/108-00000002”, “outisbusy,”) in new stack
– Executing [[email protected]:1] Progress(“SIP/108-00000002”, “”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/108-00000002”, “0?emergency,1”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/108-00000002”, “0?intracompany,1”) in new stack
– Executing [[email protected]:4] Playback(“SIP/108-00000002”, “all-circuits-busy-now&please-try-call-later, noanswer”) in new stack
– <SIP/108-00000002> Playing ‘all-circuits-busy-now.ulaw’ (language ‘en’)

Rebooted server and now it is trying to look up the Trunk Name instead of using the host entry of peer settings.

Your DNS is horked.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.